Large and complex project - issues with filtering and views

New Contributor

Hello guys,

does anyone met these issues before?



  • over 6k tasks
  • resources incl.
  • baseline used

There is something wrong - when I try to filter table, filter applies but immediately the filter buttons disappear.. Also, when trying to switch to Task usage view, it doesn't work (doesn't switch the view). Of course I tried to copy original view from template, did not work. I tried to export XML data and import it into blank new project, did not work either.


Only way I could switch into that view is to open New window with that specific view.. but that's crazy, you know..


Any ideas? ;)


7 Replies
MilanBor --

Do you have the Gantt Chart view applied when you encounter these problems? If so, this situation is very similar to a situation I encountered one time when the Gantt Chart view somehow got corrupted. Here is how I was able to resolve the problem with my project:

1. Apply any other view, such as the Resource Sheet view.
2. Display the Organizer dialog.
3. In the list of Views on the right side of the screen (in the project), select the Gantt Chart view and then click the Delete button.
4. Close the Organizer dialog.
5. Apply the Gantt Chart view again.

By using the above process, you will cause Microsoft Project to copy a fresh Gantt Chart view from your Global.mpt file to your project. Please try these steps and then test your project again. And please let us know if this process helped you.
Hi Dale,

that's exactly what I've been trying as the first option. Whatever gets corrupted should be restored from the original template.. But not this time. I tried on different systems, different versions of Project, different language versions... was not able to get it back to work :(

Thanks for any other ideas :)
Okay, here's a few questions that may help us help you.
1. What version of Project are you using?
2. Is it fully updated?
3. What language?
4. Is it a single file or part of a linked structure (i.e. master/subprojects, resource pool/sharer files)?
5. Does the file have any inserted objects (e.g. graphics, links to other apps.)?
6. What is the current file size in Mb?
7. Does the file have multiple calendars?
8. Does the file use paste links between fields (e.g. hammock tasks)?
9. How many custom fields?
10. Does the file contain macros?

You say you tried saving as XML and then re-opening the XML into a new Project file. Did the new file immediately display the same problem or did it initially work and then go south after some editing?



Hi John,

let me go through the checklist ;)

1) Tried on many different (2013/2016/2019) 32/64bit
2) Always Fully updated
3) English / Czech
4) Single file, local resources (removed work res. only material res. kept)
5) No inserted objects
6) Latest version 51.4MB
7) Yep, 8 calendars
8) Nope
9) Yep - text (11), number (6), outline number (5)
10) no VBA


When trying to import XML to new project, app crashes down with this event:




Thanks for all the direct answers. My first guess is the 8 calendars associated with your project and the fact that the XML process crashes.

Are the 8 calendars task calendars or resource calendars? You say you have removed all work resources so I'll assume the calendars are task calendars. If you temporarily delete all custom calendars (i.e. leave only the default project calendar), does the XML process work?

One other thing you might try is method 3 in this Wiki article:

Let us know.
Hi John,

I didn't have time to try removing calendars.. and yes, that method 3 from provided link has already been discussed with my client.. Unfortunately, importing data from subproject has more limits than just losing custom formatting..
- Custom fields lost
- Baseline data lost (seems like data are present in relevant fields, but Baseline is not "officialy" saved (in that master project..), so Project doesn't know about it

I was thinking about saving template from corrupted file first, but then we're risking having corrupted views as well :(


Something else must be going on because method 3 should not lose custom fields and baseline data is carried over and is "active" (i.e. responds to earned value metrics).

What exactly is "lost" with respect to custom fields? If you are referring to custom fields that have been renamed then yes, that new name will not be carried forward, it's part of the custom formatting.
What exactly is "lost" with respect to baseline data?