Error while exporting brain


I'm not able to export my brain for Moab, I keep getting the same error:

>> Error while exporting brain - Image builder failed


Not sure what the problem could be here, any help would be appreciated.

4 Replies

Hi @kirillpol - to help debug this can you navigate to Workspace info (/accounts/settings) and grab both "Workspace name" and "Workspace ID"? That should be enough for us to look for service logs to see why it's failing.


Additionally, I'd be curious to know if you see failures if you train and try to export another brain or brain version. Based on the screenshot, it looks like you have a version 2 (v02) of this brain. Can you try exporting that one assuming it has been trained as well?

@hnager Thank you! I turns out this was a problem with my Azure account. With a fixed subscription and using preview.bonsai instead of beta.bonsai it works now.

@kirillpol,  I'm glad that brain export is working for you now! For the benefit of other users who may  encounter the same issue in the future, what was the issue with your Azure account?

@hnager, It seems like it was using the old version of Bonsai ( instead of the preview and did not have a valid Azure subscription, so it allowed me to train (at that time), but it seems like exporting was not possible (as far as I could tell).