Sharepoint list not refreshing after flow writes info.

Contributor

Hi,

 

I'm not sure if this is a bug or just a feature that's not currently supported, but when a flow updates a SharePoint list, the list does not get refreshed. What I mean is that the user will need to manually refresh a browser tab (f5) in order to have the information presented on the screen. On the other hand, if two users simultaneously update the SharePoint list via classic list edit means, the information automatically refreshes, no need to refresh browser tab.

 

Is there a workaround or settings that I'm not aware of maybe?

 

Cheers

7 Replies

Hi @Nikola Nenadovic 

 

I often use Flow to update SharePoint lists and they show within seconds of flow pushing it to SP.

 

If yours isn't updating, I wonder if the browser you are using is the issue?

 

Doesn't sound like normal behaviour to me from my experience.

 

Cheers

Damien

Hi,

The flow is changing existing items and the changes are not visible in chrome, edge, firefox.. only after refreshing the page.

Cheers

Hi @Nikola Nenadovic 

 

Weird one. My flows do the same thing and the changes show... until today. I tested it and now I'm getting the same issue.

 

I am doing heavy development in Flow and SharePoint so this was working up until this week.

 

If anyone from Microsoft is reading, can you please chime in? One of my favourite features was seeing changes to SP lists without refreshing!

 

Cheers

Damien

The lists are updated when a new item is added, however when the item is changed - nothing.

@Nikola Nenadovic The new Edge browser does automatically update but it takes about 30 seconds, not ideal.

@KevDavies 

 

Now more than a year later we are still facing this behavior. 
Items changed by a flow (started from button within the list) get changed, but it takes up to 30 seconds until the list view refreshes. Confuses our users badly. 

 

Any solution or workaround for this known? 

I dont think this issue is related to flow. This is SharePoint frontend and/or browser issue. We have a infopath edit form that is launched directly from list item edit button. When we close form, 7 out 10 times list view gets refreshed upon returning to list. Sometimes, sharepoint just takes extra seconds to auto refresh the view.