SharePoint Get Items Filter Query returns unexpected results


I am using the Get Items Filter Query for a simple string comparison. However, I get zero results no matter what, even though if I run the same query in the browser with a REST url I get the results I expect.


The REST query'xxx-xxxxxx--xxxxx-xxxxx')/items?$select=Title&$filter=Title eq 'String Value'


I get the expected value of 1 record


When I enter the same query in the Flow, I get a blank result every time. I've tried several string values that I know exist. I've tried trim()'ing the string. I've confirmed that my Flow connection account has access to the SharePoint list. 


What am I not thinking of?Capture.PNG






3 Replies
best response confirmed by Courtney Prothero (Contributor)

Hi @Courtney Prothero 


Is the Title text and EmployeeText the same case?


Perhaps there's a mismatch?


In saying that, I use Filter Query as well and don't have the issue although my answers in the particular Flow are fixed so the match is guaranteed.




Thank you for responding. Checking the case is a good tip. However, in this case I think it was a backend issue. When I came back to the office after the holiday weekend I tried re-running a previous instance of the flow, without making any changes, and it worked as expected.


So maybe just an undisclosed health issue with Sharepoint on Friday. And me feeling like I was missing something obvious.


Hi @Courtney Prothero 


Glad the issue is resolved. Yeah sometimes these random things crop up but sounds like you are back on track.


Nice work!


Have a great weekend ahead!


Cheers and best wishes