SharePoint Copy Wiki Page - embedded scripts stripped from output

%3CLINGO-SUB%20id%3D%22lingo-sub-1833921%22%20slang%3D%22en-US%22%3ESharePoint%20Copy%20Wiki%20Page%20-%20embedded%20scripts%20stripped%20from%20output%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1833921%22%20slang%3D%22en-US%22%3E%3CDIV%20class%3D%22lia-message-body%20lia-component-message-view-widget-body%20lia-component-body-signature-highlight-escalation%20lia-component-message-view-widget-body-signature-highlight-escalation%22%3E%3CDIV%20class%3D%22lia-message-body-content%22%3E%3CP%3EI'm%20trying%20to%20replace%20a%20SharePoint%202010%20Workflow%20that%20copied%20a%20SharePoint%20Wiki%20Page%20file%20from%20one%20library%20to%20another.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20source%20file%20contains%20text%2C%20a%20content%20editor%20web%20part%20(that%20pulls%20in%20an%20html%20file)%20and%20an%20embedded%20JavaScript%20code%20snippet.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20original%202010%20workflow%20copies%20the%20file%20with%20no%20trouble.%26nbsp%3B%20The%20Power%20Automate%20flow%20I%20created%20copies%20the%20file%2C%20but%20strips%20out%20the%20content%20editor%20web%20part%20and%20the%20embedded%20code%20snippet.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20using%20a%20manually%20triggered%20flow%20and%20just%20the%20SharePoint%20%22Copy%20file%22%20component.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ethoughts%20on%20how%20to%20get%20the%20intact%20file%3F%3C%2FP%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1833921%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Flow%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1854110%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Copy%20Wiki%20Page%20-%20embedded%20scripts%20stripped%20from%20output%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1854110%22%20slang%3D%22en-US%22%3EI%20posted%20this%20question%20in%20the%20Power%20Automate%20community%20too%2C%20but%20got%20no%20responses%20there%20(either).%3CBR%20%2F%3E%3CBR%20%2F%3EAnyone%20have%20thoughts%20on%20this%20problem%3F%3C%2FLINGO-BODY%3E
Occasional Contributor

I'm trying to replace a SharePoint 2010 Workflow that copied a SharePoint Wiki Page file from one library to another.

 

The source file contains text, a content editor web part (that pulls in an html file) and an embedded JavaScript code snippet.

 

The original 2010 workflow copies the file with no trouble.  The Power Automate flow I created copies the file, but strips out the content editor web part and the embedded code snippet.

 

I'm using a manually triggered flow and just the SharePoint "Copy file" component.

 

thoughts on how to get the intact file?

3 Replies
I posted this question in the Power Automate community too, but got no responses there (either).

Anyone have thoughts on this problem?

Is this a scary question or has no one else tried to use power automate to copy a SharePoint Wiki page?