Send an email fails when one apply to each is blank.

%3CLINGO-SUB%20id%3D%22lingo-sub-729385%22%20slang%3D%22en-US%22%3ESend%20an%20email%20fails%20when%20one%20apply%20to%20each%20is%20blank.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-729385%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20pretty%20new%20to%20Microsoft%20Flow%20and%20have%20a%20sharepoint%20which%20automatically%20runs%20a%20flow%20when%20a%20sharepoint%20list%20item%20is%20created%20or%20modified.%20It%20only%20runs%20if%20it%20has%20not%20been%20approved%20yet.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20using%20the%20Get%20user%20profile%20and%20Get%20manager%20(V2)%20to%20get%20the%20names%2C%20email%2C%20and%20phone%20numbers%20for%20approval%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20two%20apply%20to%20each%20actions%20surrounding%20a%20Send%20an%20Email%20(v2)%20They%20are%20gathering%20the%20Business%20Phones%2C%20if%20the%20person%20submitting%20the%20ticket%20does%20not%20have%20a%20phone%20number%20it%20%22succeeds%22%20but%20does%20not%20send%20the%20email%20because%20there%20are%200%20phone%20numbers.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHow%20do%20I%20fix%20this.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-729385%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Flow%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-730537%22%20slang%3D%22en-US%22%3ERe%3A%20Send%20an%20email%20fails%20when%20one%20apply%20to%20each%20is%20blank.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-730537%22%20slang%3D%22en-US%22%3E%3CP%3EHI%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F368607%22%20target%3D%22_blank%22%3E%40James_McC%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20you%20please%20show%20a%20bit%20more%20of%20your%20flow%3F%20It%20would%20be%20helpful%20to%20see%20more%20of%20the%20flow%20and%20maybe%20even%20what's%20in%20Send%20an%20email%20(V2).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPlease%20redact%20any%20sensitive%20info%20and%20leave%20what%20you%20can%20show%20in%20the%20screen%20shot.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhat%20you're%20asking%20for%20should%20be%20straight%20forward!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECheers%3C%2FP%3E%3CP%3EDamien%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Visitor

I am pretty new to Microsoft Flow and have a sharepoint which automatically runs a flow when a sharepoint list item is created or modified. It only runs if it has not been approved yet.

 

I am using the Get user profile and Get manager (V2) to get the names, email, and phone numbers for approval

 

I have two apply to each actions surrounding a Send an Email (v2) They are gathering the Business Phones, if the person submitting the ticket does not have a phone number it "succeeds" but does not send the email because there are 0 phone numbers.

 

How do I fix this.

1 Reply
Highlighted

HI @James_McC 

 

Can you please show a bit more of your flow? It would be helpful to see more of the flow and maybe even what's in Send an email (V2).

 

Please redact any sensitive info and leave what you can show in the screen shot.

 

What you're asking for should be straight forward!

 

Cheers

Damien