Powerapp button not appearing on Modern List

%3CLINGO-SUB%20id%3D%22lingo-sub-66794%22%20slang%3D%22en-US%22%3EPowerapp%20button%20not%20appearing%20on%20Modern%20List%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-66794%22%20slang%3D%22en-US%22%3E%3CP%3EAs%20the%20title%20explains%20is%20there%20any%20reason%20why%20this%20should%20happen.%20My%20account%20has%20the%20proper%20licencing%20and%20PowerApps%20is%20enabled.%20My%20list%20is%20a%20modern%20one%20but%20no%20button.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-66794%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EPowerApps%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-68091%22%20slang%3D%22en-US%22%3ERe%3A%20Powerapp%20button%20not%20appearing%20on%20Modern%20List%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-68091%22%20slang%3D%22en-US%22%3E%3CP%3EAwesome.%20Thanks.%20I%20will%20sit%20and%20wait%20patiently%20then.%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-68088%22%20slang%3D%22en-US%22%3ERe%3A%20Powerapp%20button%20not%20appearing%20on%20Modern%20List%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-68088%22%20slang%3D%22en-US%22%3E%3CP%3ETeam%20site...and%20it%20was%20at%20least%20an%20hour.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-68081%22%20slang%3D%22en-US%22%3ERe%3A%20Powerapp%20button%20not%20appearing%20on%20Modern%20List%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-68081%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20for%20the%20details.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20found%20the%20setting%20and%20I%20just%20turned%20this%20on.%20How%20long%20did%20you%20have%20to%20wait%20for%20it%20to%20appear%3F%20And%20is%20your%20Modern%20list%20part%20of%20a%20Modern%20Team%20Site%20or%20is%20part%20of%20a%20standard%20SharePoint%20Team%20site%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-68073%22%20slang%3D%22en-US%22%3ERe%3A%20Powerapp%20button%20not%20appearing%20on%20Modern%20List%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-68073%22%20slang%3D%22en-US%22%3E%3CP%3ENot%20to%20my%20knowledge.%20We%20have%20been%20on%20O365%20for%20three%20years%20now%20with%20E3%20and%20K%20licenses.%20I%20have%20never%20done%20anything%20with%20a%20Preview%20license.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-68072%22%20slang%3D%22en-US%22%3ERe%3A%20Powerapp%20button%20not%20appearing%20on%20Modern%20List%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-68072%22%20slang%3D%22en-US%22%3E%3CP%3EDid%20you%20have%20the%20preview%20licenses%20available%20in%20your%20tenant%20prior%20to%20GA%3F%20I%20had%20signed%20up%20for%20the%20preview%20orginally%20so%20I%20wonder%20if%20there%20is%20some%20sort%20of%20correlation.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAlso%2C%20where%20are%20you%20seeing%20the%20option%20to%20Enable%20the%20Preview%20specifically%20within%20the%20SP%20Admin%20Center%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-68064%22%20slang%3D%22en-US%22%3ERe%3A%20Powerapp%20button%20not%20appearing%20on%20Modern%20List%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-68064%22%20slang%3D%22en-US%22%3E%3CP%3EI%20found%20that%20I%20did%20in%20fact%20have%20to%20enable%20the%20Preview%20option%20within%20SP%20Admin.%20Not%20sure%20why%20this%20is%20the%20case%20since%20these%20functions%20have%20been%20GA%20for%206%20months.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-68062%22%20slang%3D%22en-US%22%3ERe%3A%20Powerapp%20button%20not%20appearing%20on%20Modern%20List%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-68062%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20seeing%20this%20in%20my%20Tenant%20as%20well.%20We%20actually%20have%20a%20handful%20of%20people%20that%20went%20to%20SharePoint%20Satruday%20this%20weekend%20and%20are%20trying%20to%20test%20out%20PowerApps%20but%20nobody%20can%20see%20it.%20We%20are%20licensed%20but%20interestingly%20enough%20I%20pulled%20a%20report%20from%20the%20PowerApps%20Admin%20Center%20and%20it%20appears%20that%20even%20though%20users%20are%20licensed%20it%20isn't%20registering%20as%20such.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-67288%22%20slang%3D%22en-US%22%3ERe%3A%20Powerapp%20button%20not%20appearing%20on%20Modern%20List%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-67288%22%20slang%3D%22en-US%22%3E%3CP%3EDoes%20%22%3CSPAN%3EEnable%20preview%20features%22%20need%20to%20be%20set%20in%20the%20Sharepoint%20Admin%20Settings%3F%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-67276%22%20slang%3D%22en-US%22%3ERe%3A%20Powerapp%20button%20not%20appearing%20on%20Modern%20List%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-67276%22%20slang%3D%22en-US%22%3E%3CP%3EDid%20some%20additional%20testing%20and%20found%20the%20following%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20seperate%20tenant%26nbsp%3B%3CSPAN%3E%20(Sharepoint%20version%2016.0.0.6420)%20where%20the%20PowerApps%20and%20Flow%20buttons%20appear%20on%20lists.%20Only%20Flow%20appears%20on%20libraries%20in%20that%20tenant.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EMy%20primary%20tenant%20(Sharepoint%20version%2016.0.0.6427)%20is%20not%20showing%20the%20buttons%20in%20either%20a%20library%20or%20a%20list.%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3ESince%20my%20primary%20tenant%20has%20a%20new%20SP%20version%20than%20the%20test%20tenant%20I%20am%20led%20to%20think%20that%20I%20must%20have%20%26nbsp%3Ba%20setting%20turned%20off%20for%20my%20license.%20These%20are%20both%20Office%20365%20E3%20accounts%20and%26nbsp%3Bin%20my%20primary%20the%20following%20are%20not%20turned%20on%20where%20there%20are%20enabled%20in%20the%20test%20tenant%3A%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EMS%20Teams%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EYammer%20Enterprise%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3ECould%20either%20one%20of%20these%20be%20related%20or%20could%20there%20be%20something%20else%20disabled%20that%20should%20be%20enabled%3F%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-66878%22%20slang%3D%22en-US%22%3ERe%3A%20Powerapp%20button%20not%20appearing%20on%20Modern%20List%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-66878%22%20slang%3D%22en-US%22%3E%3CP%3EI%20see%20no%20Powerapps%20button%20on%20any%20list%20within%20any%20site.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-66874%22%20slang%3D%22en-US%22%3ERe%3A%20Powerapp%20button%20not%20appearing%20on%20Modern%20List%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-66874%22%20slang%3D%22en-US%22%3EIs%20it%20happening%20only%20in%20that%20list%20or%20also%20in%20other%20ones%20living%20in%20the%20same%20site%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-693619%22%20slang%3D%22en-US%22%3ERe%3A%20Powerapp%20button%20not%20appearing%20on%20Modern%20List%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-693619%22%20slang%3D%22en-US%22%3EAre%20you%20STILL%20waiting%3F%3C%2FLINGO-BODY%3E
Highlighted
Deleted
Not applicable

As the title explains is there any reason why this should happen. My account has the proper licencing and PowerApps is enabled. My list is a modern one but no button.

12 Replies
Highlighted
Is it happening only in that list or also in other ones living in the same site?
Highlighted

I see no Powerapps button on any list within any site. 

Highlighted

Did some additional testing and found the following:

 

I have a seperate tenant  (Sharepoint version 16.0.0.6420) where the PowerApps and Flow buttons appear on lists. Only Flow appears on libraries in that tenant.

 

My primary tenant (Sharepoint version 16.0.0.6427) is not showing the buttons in either a library or a list. 

 

Since my primary tenant has a new SP version than the test tenant I am led to think that I must have  a setting turned off for my license. These are both Office 365 E3 accounts and in my primary the following are not turned on where there are enabled in the test tenant:

 

MS Teams

Yammer Enterprise

 

Could either one of these be related or could there be something else disabled that should be enabled?

 

Highlighted

Does "Enable preview features" need to be set in the Sharepoint Admin Settings?

I am seeing this in my Tenant as well. We actually have a handful of people that went to SharePoint Satruday this weekend and are trying to test out PowerApps but nobody can see it. We are licensed but interestingly enough I pulled a report from the PowerApps Admin Center and it appears that even though users are licensed it isn't registering as such. 

Highlighted

I found that I did in fact have to enable the Preview option within SP Admin. Not sure why this is the case since these functions have been GA for 6 months. 

Highlighted

Did you have the preview licenses available in your tenant prior to GA? I had signed up for the preview orginally so I wonder if there is some sort of correlation. 

 

Also, where are you seeing the option to Enable the Preview specifically within the SP Admin Center?

Highlighted

Not to my knowledge. We have been on O365 for three years now with E3 and K licenses. I have never done anything with a Preview license.

Highlighted

Thanks for the details. 

 

I found the setting and I just turned this on. How long did you have to wait for it to appear? And is your Modern list part of a Modern Team Site or is part of a standard SharePoint Team site?

Highlighted

Team site...and it was at least an hour.

Highlighted

Awesome. Thanks. I will sit and wait patiently then. :)

Highlighted
Are you STILL waiting?