Power Automate sending too many variables to PowerApps

%3CLINGO-SUB%20id%3D%22lingo-sub-1157961%22%20slang%3D%22en-US%22%3EPower%20Automate%20sending%20too%20many%20variables%20to%20PowerApps%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1157961%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20Power%20Automate%20connected%20with%20Power%20Apps.%20The%20App%20sends%20a%20lot%20of%20information%20to%20P.Automate%20and%20he%20uses%20it%20to%20calculate%20some%20variables%20and%20write%20some%20lines%20in%20a%20List.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20changed%20the%20name%20of%20the%20variables%20and%20now%20i'm%20receive%20them%20doubled%2C%20which%20obviously%20makes%20the%20PowerApps%20expect%2036%20variables%20instead%20of%2026%2C%20I've%20tried%20deleting%20the%20P.Automate%20and%20create%20it%20again%20and%20'Saving%20As'%20but%20nothing%20helps%2C%20I%20attach%20a%20pic%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20red%20the%20old%20variables%20marked%2C%20which%20are%20followed%20by%20the%20same%20variables%20with%20the%20correct%20name%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22IssuesVariablesPowerApps.png%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F169599i3C7062620567E249%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22IssuesVariablesPowerApps.png%22%20alt%3D%22IssuesVariablesPowerApps.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20there%20any%20way%20of%20'explaining'%20to%20PowerApps%20or%20Power%20Automate%20to%20read%20correctly%20the%20variables%20that%20it%20should%20expect%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EJRR%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1157961%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Flow%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EPowerApps%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1594546%22%20slang%3D%22en-US%22%3ERe%3A%20Power%20Automate%20sending%20too%20many%20variables%20to%20PowerApps%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1594546%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F362975%22%20target%3D%22_blank%22%3E%40Azaak%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhat%20do%20we%20have%20to%20do%20to%20get%20this%20question%20addressed.%20If%20its%20not%20possible%20can%20this%20go%20in%20the%20Dev%20group%20form%20Power%20Platform.%20Its%20an%20irritation%20to%20say%20the%20least%20and%20The%20best%20way%20to%20resolve%20it%20is%20to%20recreate%20the%20flow%20carefully%20not%20to%20do%20it%20again.%20ALSO%20if%20you%20do%20not%20name%20the%20method%20the%20identifying%20name%20it%20will%20show%20up%20as%20initialize_variableXX%20every%20time.%20There%20is%20no%20way%20to%20identify%20what%20variable%20its%20asking%20without%20cross%20referencing%20my%20flow.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPlease%20look%20into%20this%20Sorry%20Azaak%20for%20not%20being%20your%20response%20after%206%20months.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Hi

 

I have a Power Automate connected with Power Apps. The App sends a lot of information to P.Automate and he uses it to calculate some variables and write some lines in a List.

 

I've changed the name of the variables and now i'm receive them doubled, which obviously makes the PowerApps expect 36 variables instead of 26, I've tried deleting the P.Automate and create it again and 'Saving As' but nothing helps, I attach a pic:

 

In red the old variables marked, which are followed by the same variables with the correct name:

 

IssuesVariablesPowerApps.png

 

Is there any way of 'explaining' to PowerApps or Power Automate to read correctly the variables that it should expect?

 

Thanks!

 

Regards,

 

JRR

1 Reply
Highlighted

@Azaak 

 

What do we have to do to get this question addressed. If its not possible can this go in the Dev group form Power Platform. Its an irritation to say the least and The best way to resolve it is to recreate the flow carefully not to do it again. ALSO if you do not name the method the identifying name it will show up as initialize_variableXX every time. There is no way to identify what variable its asking without cross referencing my flow. 

 

Please look into this Sorry Azaak for not being your response after 6 months.