Flows have suddenly started running slowly

%3CLINGO-SUB%20id%3D%22lingo-sub-1411249%22%20slang%3D%22en-US%22%3EFlows%20have%20suddenly%20started%20running%20slowly%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1411249%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20number%20of%20flows%2C%20one%20main%20one%20has%20up%20to%20this%20fault%20never%20taken%20more%20than%202.5%20hours%20to%20run.%3C%2FP%3E%3CP%3EThe%20last%20run%20I%20canceled%20after%2015%20hours!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThese%20flows%20only%20use%20excel%20for%20business%20(Files%20on%20onedrive)%20and%20365%20outlook.%20It%20would%20appear%20that%20the%20apply%20to%20each%20after%20reading%20the%20excel%20data%20is%20what%20is%20taking%20the%20time.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOne%20point%20noticed.%3C%2FP%3E%3CP%3EBefore%20it%20started%20running%20slowly%2C%20if%20you%20looked%20at%20the%20running%20flow%20you%20would%20have%20green%20ticks%20against%20the%20completed%20steps%2C%20and%20a%20clock%20on%20the%20running.%20Now%20there%20is%20no%20%22running%22%20step%20displayed.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20ideas%20as%20to%20the%20cause%3F%20And%20a%20solution%20please%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBest%20wishes%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMark%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1411249%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Flow%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
New Contributor

Hi,

 

I have a number of flows, one main one has up to this fault never taken more than 2.5 hours to run.

The last run I canceled after 15 hours!

 

These flows only use excel for business (Files on onedrive) and 365 outlook. It would appear that the apply to each after reading the excel data is what is taking the time.

 

One point noticed.

Before it started running slowly, if you looked at the running flow you would have green ticks against the completed steps, and a clock on the running. Now there is no "running" step displayed.

 

Any ideas as to the cause? And a solution please?

 

Best wishes

 

Mark

0 Replies