Term Store vs Flow Output

Copper Contributor

I'm hoping for some advice, I'm banging my head off a wall with this one. 

 

I have a very simple SharePoint list, one column in the list pulls a list of companies from our term store. The form can be completed successfully and submitted, the flow outputs the email like it's supposed to, however, for the life of me, despite checking, double checking and triple checking, I can't get the company name to output. 

 

The assumption being that the "label" is the correct output to give me the relevant term, from the term store. 

 

I have tried all of these options:

 

Steve_Bremner_0-1706807012536.png

 

 

They all output their relevant data, however "Label" simply outputs a number, it's not the GUID or value, however the "Label" outputs the same results as the WssId, in the below case, 19. The number 19 doesn't feature anywhere in the term, the number changes dependant on the term. 

 

{"@odata.type":"#Microsoft.Azure.Connectors.SharePoint.SPListExpandedTaxonomy","TermGuid":"0e83310c-22f7-4da8-af20-d5a8119e281d","WssId":19,"Label":"19","Value":"19|0e83310c-22f7-4da8-af20-d5a8119e281d"}

 

Annoyingly, this setup worked fine at the last company I worked for, so I'm utterly stumped why it won't output now. 

 

6 Replies
@Steve_Bremner you can use id also if label is misbehaving,
use action to get list item from taxonomyhiddenlist and use id in req column.
maybe it will get display name as desired
Thanks for the response, I'll have a check and will come back with an update.
Ok so I finally got round to having a check in the taxonomyhiddenlist, I had no idea that place existed, very hand to know thanks!

I tried a few other of the listed IDs in there, but still nothing. It's very odd. Any other potential issues you can think of? Appreciate the advice!
I now have a very strange plot twist.

So I created a new list that uses the same term set. Created my flow, and it outputs no problem at all.

However, it's since stopped for some reason, I edited some of the email contents, nothing that I thought would impact the flow, but clearly it's done something. I'm now even more bamboozled! ha ha ha
hm, maybe you want to share export of the flow? its hard to say why its not outputting label. In cases like this i usually start from fresh,create new test site collection+new test term+new flow
There has to be something in the flow, some kind of conflict with another item. To be honest, I'll put it on the back burner for just now thanks. It's not really a huge issue asking users to manually type a field. :) Thanks again, much appreciated.