SP List, Something went wrong. Cannot read property'indexOf' of undefined. POWER AUTOMATE

Copper Contributor

Hi All,

When I try starting a flow by selecting a list item & click on AUTOMATE , I get this ERROR


What I noticed is this error comes up only in lists that have got LOOKUP COLUMNS (checked this in 3 separate lists with lookup columns).

Everything works normally in lists without lookups columns. 

For more info, I do not have more than 100 items in my lists.
This problem started like 3 hours ago.
My flow gets triggered by selecting the list item & running it.

I am not sure if the problem is on Microsoft side. 

Thank you,

10 Replies

We also have the same problem on the O365 - Company EIFFAGE environment.




Did you check the view itself?

Did you check if the max number of lookups in a list is exceeded?
Make a new view and test it
I checked and the max number is 30. I created a view but the problem is still present.
I have checked the views and all. Items show up, no problem. The problem shows up when you select an item and click on AUTOMATE.
I have 3 lists and in one of them, I only have 5 items with one 1 look-up column.
The same error shows up.
Can you send more details?
Sharepoint version, view you are using, screen print from the view you ar using
The names of the lookup fields (where are they referring to - which lists?)
Anything that might be helpful to reproduce
Add a word doc as an attachment please.
Will try to see if i can help you

@Hegelmat I also have this exact same problem.  It was all fine last week and I've changed nothing!

Hi Andre,
I was using the modern version.
I had 3 separate lists with different types of look-up columns. I even created views to remove the lookups columns, and the number of items. The problem was still there.
Lists were different in size which made me discard the max lookup columns/views issue.

Luckily , it was fixed (by itself) on the following day.
I would still want to know the cause as it negatively affected our production environment.
Thank you.
Luckily it got fixed the following day.
Still scary as I dont know when this issue might happen again.

 We are facing similar issue now it was working till Monday but now I am getting this error message. strange thing is issue is not with all items in list but most of the items in a list having this issue.

did we got any fix for this?



Unfortunately I never got to the bottom of it in terms of troubleshooting. Cutting down List size, lookUp columns, Views etc did not resolve the issue.
It justs fixed itself the following day.
Because our team heavily depends on that flow , I had to find a quick workaround.
I replaced the "For the selected item" TRIGGER with a manual one that asks the item ID. 
Extra step but it worked smoothly.