Sharepoint list permissions Microsoft Flow

Brass Contributor

I am trying to create a Flow that will generate a PDF when an item is submitted to a SharePoint List and cannot get the First Step in the Flow to work.


When using a Service Account, Flow is not showing any Site Addresses or List Name's.









This service account is in the "SiteName Owners" group, but does not see any items in the "Site Address" list.



When using my User Account, Flow showing items for "Site Address" 















However, it will not show any list, even though it is in the Owner's group of the Site that the List is inheriting permissions from.










Does anyone have any idea why the discrepancy and why I cannot see any "List Name" items once a site is selected that does indeed have lists that we are submitting to?

5 Replies

Hi @Brandon McGinnis 


You may have missed a step. Make sure you click onto Enter custom value first before you paste the site address URL.


Don't forget to ensure that the service account has full access to the SharePoint site so you don't get stitched up in issues later down the track.


Cheers and best wishes


@Damien Rosariothank you for the suggestions!

I don't need to enter a Custom Value, it should appear in a site dropdown list.

The service account is in the "SiteName - Owners" group so I would assume that is what you mean?

Hi @Brandon McGinnis 


I agree that it should show up in your list and I'm not across any technical reasons why it wouldn't show (I'll leave it to the experts to comment on), but when it doesn't show, using the Enter custom value is just as effective.


I use this method as the way forward in my Flows and I hope it has given you the way forward for your issue too.


Cheers and best wishes


@Damien Rosario the issue is that "Tasks" and a regular SharePoint List are treated differently by Flow.

I tested by creating a regular Sharepoint List and it showed up in the dropdown of available items where the Tasks list did not.

Using the "Custom Value" for the "Tasks" list worked though and I was able to create the Flow.

I'm glad to hear it worked, @Brandon McGinnis. I get the frustration but I suppose that's what the custom value is for in those type of instances. Perhaps they'll fix this up as the product evolves.


Best wishes with your Flows and the weekend ahead!