PowerApp forms get stuck on "Getting your data..."

Deleted
Not applicable

Some, but not all of my SharePoint Forms that are built using PowerApps are getting stuck saying (Getting your data...".  The strange thing is that sometimes the data will load then this will happen, or I can click out of the form and reopen it and then it will work.  Anyone experiencing a similar issue?  

49 Replies

Yes I have experienced the same issue multiple times. 

"Getting your data" issue in Power Apps typically occurs when the app is taking too long to load data from a data source, like SharePoint, SQL Server, or any other connector. To fix this issue, you can follow these steps:

Optimize your data source:

a. Reduce the number of columns and rows in your data source, if possible.
b. Use indexes on your data source to speed up data retrieval.
c. Filter data at the source level instead of within the app.
d. For SharePoint, use the "Delegation" feature for large data sets.

Optimize app performance:

a. Use the 'Concurrent' function to load multiple data sources simultaneously.
b. Limit the number of items returned by using the 'Top' function in the 'Filter', 'Sort', or 'Search' functions.
c. Use the 'Set' function to store data in variables, and work with the variables instead of directly with the data source.
d. Use collections to store data in memory, and update the data source only when necessary.
e. Replace complex formulas with simpler ones, if possible.

Optimize controls and UI:

a. Limit the number of controls on each screen, and use galleries or tabs to organize content.
b. Use the 'Visible' property to load controls only when they are visible on the screen.
c. Use the 'OnVisible' property to execute actions when a screen becomes visible, rather than loading everything at once when the app starts.

Check your app's connectors:

a. Ensure that the connectors are properly configured and authenticated.
b. Check for any changes in the data source or connector settings that might be causing the issue.
c. Make sure the connector being used is supported and maintained by Microsoft.

Test on different devices and networks:

a. Test your app on various devices and network connections to ensure it is not a device or network-specific issue.
b. Use the Power Apps Monitor to analyze the app's performance and identify any potential bottlenecks.

Review the app's version history:

a. If the issue started happening recently, review your app's version history and check for any changes that might be causing the problem.
b. Revert to a previous version of the app if necessary, and test for improvements.


Hi, I am having the same problem and I tried the below solutions but didn't work.

My first problem was not seeing the Form1 when I run the application.
I saw two ways to resolve this problem:

1. Change Default Mode from Edit to New
2. Or add First('Test Sample list') into Item when the Default Mode is Edit

both work fine. However, in both versions, if I reach the app via the link I see Getting your data message.

I tried to add ResetForm(Form1); RequestHide() but it didn't work. I tried to add what @Sheldor suggested.
If(IsBlank(SharePointIntegration.Selected) || IsEmpty(SharePointIntegration.Selected),First('insert data source name'),SharePointIntegration.Selected)

But I am getting an error for SharePointIntegration because I think I didn’t use it.

What I did is, I created a list in SharePoint (5-6 columns, empty data) and then I connected this to PowerApps.

My aim is only to submit new data to this list.
How can I overcome this problem?

Thanks @Sheldor 

 

This is what worked for me, I added this to the OnSuccess field of the form

 

Navigate(Screen2);
ResetForm(Form1);
RequestHide()

 

Where:

 

Screen2 is the name of the screen I want to navigate to after the form is successfully submitted

Form1 is the name of the form.

I am having a the same issue but my app is set up a little differently, I have a home screen that is just buttons to navigate to different screens. The actual form is a splir of a couple things. A couple custom input fields and a repeating field gallery. Due to the requirements, this (and not the edit form) was the only way to do it. Due to this I don't actually have a form control per se. My app gets stuck on getting your data right when I start it. Any ideas? 

@darrenmuscat this solved it for me!!! Thanks!

@Sheldor 

 

I am also facing the same issue when using the Power App within Power BI. This issue seems to occurring with Sharepoint List. When trialing the input in App the fileds get populated perfectly into SharePoint List however through Power BI is stuck at "Getting your Data".

 

My Form on Success is as per below

Notify("Hospital Rating updated successfully",NotificationType.Success,2000); Navigate(Screen1); ResetForm('Hospital Rating'); RequestHide()
 
Any suggestions ?

The 'Getting your data' error often occurs when there's a mismatch between the display names used in SharePoint and Power Apps. This discrepancy can lead to issues in data retrieval and filtering. In my experience, using the email address instead of the display name helps to avoid this problem because email addresses are unique and consistent across both platforms. By filtering based on email addresses, you can ensure that the correct data is fetched without encountering the mismatch error.