PowerApp forms get stuck on "Getting your data..."

Deleted
Not applicable

Some, but not all of my SharePoint Forms that are built using PowerApps are getting stuck saying (Getting your data...".  The strange thing is that sometimes the data will load then this will happen, or I can click out of the form and reopen it and then it will work.  Anyone experiencing a similar issue?  

49 Replies

If it's an Edit form, make sure it has a record stipulated in the Items property - otherwise it tends to show up as a blank form when you run the app.  You need to tell it to start at the first field or it gets lost in BFE. I tried many crazy suggestions for a couple of hours and this one finally worked and actually made sense. The Item's property for an Edit form is usually linked to a gallery selection somewhere else, but I'd need some more info to determine if this is the case for this app - for now set it to 

First(yourSourceName)

where yourSourceName is your SharePoint list connection - if that doesn't work I'll need some more info 

This totally worked for me.  I guess for some reason when I started with a new form on my screen the Item field didn't auto-populate or something.  Putting the text in you suggested worked like a charm.  It pulls the data into the form now.  When you click the edit button you can edit, however if you pull the form up in view, then click edit all, it doesn't switch over to edit.  I'm going to keep digging on this.  

@Sheldor 

@Greg_Guth 

 

Thank you! This fixed my issue.

@Sheldor I've tried your method to "Getting your data" issue on another form I was working on, and I'm getting a message that reads "Delegation warning....  The "First" operation is not supported by this connector."  Would you happen to know how to fix this issue?

Just came across this page while searching similar problem but in New Form. If always stuck in "getting your data" or "No Item to Display", select the Form and in Properties make select Default Mode as New.

 

darrenmuscat_0-1592809548270.png

 

@Sheldor Hi, Thanks for this help. I did just you directed in your reply, however my app is telling me that the SharePointIntegration identifier isn't recognized. What do you suggest can be done?

 

@darrenmuscat This worked for me on an OOB form.  Thanks!  Don't really understand why it fixes the issue, so I'll research that a bit more, but it works, and that's all that matters.  Thanks again!

@adityabajaj I created an account just to say thank you.

@Sheldor - I'm facing something similar issue "Getting your data", for the certain user they cannot see the data, while I use the formula on Item of Form (Query on Powerapps)

 

If(IsBlank(SharePointIntegration.Selected) || IsEmpty(SharePointIntegration.Selected),First('insert data source name'),SharePointIntegration.Selected) 

But the user still see the blank form (Error on Powerapps) 

@Carolina_MiC  I'm with you on this.  Did you get any feedback from support?  The "fixes" in this post appear to be workarounds to a root problem with power forms and SP.  I found it best to simply delete all versions of form and start over.  My list is quite simple though.

In your "Tree View" (left side of your screen) select the Form then at your screen right side in th "Default Mode" select "New".

@Alan Chai This worked for me today. Thank you. I love the Power App Community!

@Greg_Guth 


@Greg_Guth wrote:

If it's an Edit form, make sure it has a record stipulated in the Items property 


Perfecto! I had a multi-screen form and while I configured the Item property for the first screen I did not configure it for the other screens so they didn't load.

@Faheem_Zafar 

Thanks for sharing, this solved my problem after days of research. 

Cheers

this works for me with Excel tables.
*ID = table column name

If( IsBlank(
LookUp('table_RequestData', ID <> "")
),
First(table_RequestData),
LookUp('table_RequestData', ID <> "")
)

@Carolina_MiC how did it turn out?

 

Worked for me . Thank you very much.

I simply switched the Default mode of the form to new, i had it set to edit as modified the form to custom after the initial data connection. This fixed the issue for me.

I personal like to add the form attributes separately so i can position them without the constraints of then within the form section, but this does lead to issues when you start adding the verification later on in the build as many of the validation features are embedded within the form attribute.

After days of googling this is the best answer that worked for me. Thanks! ;)

Hi

from the other comments about re-ordering the functions on the form I thought the form should be reset at the start, so that's what I did.

Select App (top of left Pane)

Set property 'OnStart' to Reset(Formname)

It worked a treat!

But I never would have got there on my own, so thanks Alan Chai