Flow won't send me an email

Brass Contributor

I am trying to create my first flow and so I thought that I would start with something simple!


I am trying to send myself an email when a new file is added to a document library.


I am receiving an error at the send email stage. Looking at the error message I can see that in the Body section there are these lines:


"status": 401,

"message": "Unauthorized",


Can anyone tell me what I have done wrong? or what else I need to turn on?


I have tried to do this twice - once from a template email and once from a blank one - both times it fails in the same way.





PS - does anyone know if I should I be able to create a Premier Support ticket for Flow? I can't find it in the list

9 Replies
I don't think that you can create Premier support tickets yet because it is still in preview. However, you can create a ticket from the O365 Admin Center.

Have you registered your account in the Flow site?

Dean, thanks for the reply,


>>Have you registered your account in the Flow site?

 - I'm not sure what you mean - sorry for being a pain.


I am logged into Flow with my account.

I have permissions to the Site Collection.


I'll have a look around but if you can be a bit more explicit that would be a help.




I also should have added that we are Office 365 customers using ADFS in a hybrid configuration - if that makes any difference.




There are a lot of moving parts and since this is still in Preview mode, some of the instructions seem to be incomplete. In my recent testing, i learned that my testers needed to be in the First Release program so that they could see Flow and PowerApps on the Command Bar in a new modern style list.

There is also a Power Apps and Flow License, that may need to be assigned, but I have not been able to confirm this.

For reasons that only MS can understand, there is another Community at https://powerusers.microsoft.com/t5/Microsoft-Flow-Community/ct-p/FlowCommunity which has a lot more activity than this space, i would recommend asking your question there and you should get some more responses.

Dean, thanks again.


No matter what I do I can't sign in to that other site - it keeps sending me around in circles :(


I'm pretty sure I've got all the right licences, maybe my flow permissions need refreshing?


Anyway I'll battle on.




Paul does the Flow show success when logged onto your email acount ?

Dean / Ian,


I have found out what my problem is - our users are not able to grant consent to the application.




I tried the same thing with a admin enabled account and it worked fine.


I'm now talking to someone else in my team and trying to find out why this is switched off.


It was confusing though because in the Flow screens it shows all of my connections with 'green ticks'.



My client has a Bluecoat Proxy server that is causing us some issues.  This scenario is not something that is addressed in the documentation.

Dean, we also use a proxy server.


Anyway I've now created a premier support ticket about the pros and cons of turning on user consent for applications, naturally our security guys won't just let us do it. We need to know what turning it on actually means, what risks does it set up us for etc.