Users not receiving email notification for task assignment

Steel Contributor

Users haven't been receiving an email when a task is assigned to them. They do, however, receive an email when a task they're assigned to is commented on or is marked completed (discovered this wasn't the case after further testing. The user will not receive an email until they are @ mentioned). If the user is subscribed to the Plan/Group, they will receive an email, but they also receive an email for everything, which is not what we want.

 

Is this a known issue/bug? ETA on a fix? Trying really hard to roll out Groups and Planner here, but this issue is making it difficult for me to get people on board (continues the notion that Office is "hard to use").

 

According to this Support page, users should be receiving and email when a task is assigned to them: https://support.office.com/en-us/article/Get-email-about-your-tasks-and-plans-cce223d6-b0ae-43cf-a08...

20 Replies
It's not a bug...Microsoft changed how Plans are created: by default plans are created with the Send notifications about task assignment and task completion to the Plan's conversation feed. disabled so that's the reason why you are not receiving e-mails when a task is assigned or completed...to fix it, just edit the plan and enable that setting

Ok, I've enabled "Send notifications to conversation feed" on the Plan, and while a task assignment is now showing up in Conversations, the person the task was assigned to still does not receive any notification; they aren't actually tagged in the message. If I comment on the task, I receive an email, but the person assigned does not.

So unless the person subscribes to the group/plan (e.g. turns on the "fire hose"), they won't know a task was assigned to them unless either 1) They check planner 2) they read through the whole group feed and see a task was assigned to them or 3) In a reply to the task someone manually @ mentions them. This seems ridiculously inefficient. Either they aren't notified at all or if they subscribe they get so much noise that the important information is lost.

It might be a problem in your tenant...in my tenants Planner is working as expected

We encounter similar problem. Our users receive notifications to spam folder or did not receive it at all. We contact support and currently, Planner team fix settings in our tenant from Preview period and e-mail notification starts working. But in different way, as you say.

 

Currently users receiving notifications only, if they are subscribed to Group conversations. But I know, that support page say this is not neccesary to receive notification if task is assigned to someone. But it looks like, that it is not this case. Planner team maybe change something a lot of more, but not tell us.

This is happening to my group as well.  I really new this fixed for planner to be usable.

Recently I have stopped receiving emails when I assign a task in planner. Every other person in the group gets an email except me. If I comment or mark complete I then get an email. I am subscribed to the group. I have unsubscribed and aubscribed again but hose particular email are not reaching me. 

 

At this point, along with other imperfections, I am thinking that Planner is not yet ready for my organization to utilize as a tool.

Is there any news on this topic? Im am struggling with the same issue...

Hi! We got contact with Microsoft Support. After escalation with Development Team, we find out, that one settings in our tenant was not correctly updated after some infrastructure change. After service change, notifications coming from correct address and in same manner. But not in way, as we liked before.

Notifications still don't seem to work reliably unless users are subscribed to the Plan/Group, which in larger groups is completely counterproductive (drinking from a firehose). They did seem to be sort of working for a while as long as the option "Send notifications about task assignment and task completion to the Plan's conversation feed" was checked, but that no longer appears to work in my tenant.

 

Notifications are supposed to be coming to the mobile apps "soon", so maybe we'll get email notifications then, too.

I'm having issues where I can't get any Planner individual notifications to work at all. We're Exchange On-Premises (not hybrid) and have a case open trying to get more details. If anyone can help let me know!

Some plans I was getting emails, others I was not. Note: I only get emails on the plans that work when I have the following cases on a task:

  • Comment
  • Reassign
  • Complete

 

No emails on a NEW task being assinged to a user. That seems to be just how it is.

 

To check if the email users settings is enabled:

If you are the OWNER of a plan:

In Planner on your plan, go to "..." and go to "Edit Plan". Then make sure "send notifications..." is checked.

 

If you are a user, you can go to "..." and subscribe to updates. But this is per user.

 

There seems to be a lot of confusion around this.  The crux of the problem is the difference between emailing users directly and email notifications in the plan / group conversation feed.  The setting that owners can turn on is to have an email sent to the Group's conversation feed - unfortunately, so far as I can tell, this feed shows all activity for all tasks in the Group's plan so users have to trawl through to see what's relevant for them.

 

What would be far easier, and what everyone has been asking for for a year, is for any user assigned to a task to be emailed directly when they are assigned to a task or when any changes are made to it.  The Planner tool will not be of any use to most organisations until this basic update functionality is added.

Ended up finding out you have to be at least Exchange Hybrid, if not full Exchange Online for email notifications to work. Would be nice if this was clear in the product :)

We have the same issue. You are quick at dismissing others!

@Adam Fowler Can you link the article that says this?

Modern technical support: create forum where users can flounder around together trying to solve the problems with the Betaware on their own. Thank you to Microsoft for all of your help!
I am having the same problem. Trying to use "Tasks By Planner and To Do" (who came up with this name??) as an add-in to Teams. I have added TbPaTD as a tab to a Teams channel, and created a bunch of buckets to dump tasks into. But, I don't seem to have any of the options that are mentioned in this discussion. There does not appear to be an ellipsis (...) for the entire Plan, and clicking on any of the ellipsi assoicated with each bucket or task has no "Settings" or other options relevant to messaging. So at this point I have no confidence that Team members are receiving their task assignments or updates unless they happen to go look at their TbPaTD snap-in within Teams (which defeats the purpose).

@ThunderbirdsAreGo Tasks By Planner and To Do is a Teams app and annoyingly doesn't provide a link to the Planner site where you can change Notification preferences. To do this, open your web browser to https://tasks.office.com/ and you will be able to see the Plans to which you can contribute and the "..." widget where you can adjust your Plan Settings > Notifications

NBelham_0-1653044960700.png

 

We are trying to implement work with the “Planner” application. And we had a problem with email notifications for events in Planner.
We are faced with the fact that the notification does not always arrive and depends on some parameters set in the task.
The help says that messages in the mail will be sent to participants if in the “Plan Options” section of a specific Plan you check the “send messages to the group” checkbox, then notification letters will be sent. We did it.
And it clearly says “When adding a comment to a task, a message is always sent to the group.”
And then miracles begin, which may be simply explained if you know the mechanism of operation, but it is difficult for us to understand the logic without additional experiments.
What's really going on?
In fact, when adding a comment to a task, a message to the group about the new comment is not always sent.
Everything is somehow very complicated and at the same time simple, but the logic is incomprehensible and it is not clear how to fix the problem.
How it really works! An employee of a group of a specific Plan will begin to receive messages in the mail about new comments in a specific task, only after he writes at least one of his comments in this specific task of this plan.
But it definitely turned out that when you create a new task and assign it to, for example, two employees (add them to the “Assigned” for this specific task), both receive a letter stating that the task has been assigned to them, but do not receive anything further by mail for now they will not write at least one comment in this particular task.
The logic is unclear.
As if we made a “New Plan” and added “Participants” there, and added them to “Assigned”, I would like that after that they would receive letters about what is happening in this plan.
What are we doing wrong? Or what is the logic behind sending an email message about changes in a specific task?
PS:
It was also noticed that sending a message regarding changes in a specific task to the Director of a specific task begins to work if, for example, you set the “Progress” item to the “In progress” state and additionally set the date of the “Start Date” item for a specific task. Apparently, this factor works for the one who set the task and he begins to receive messages about changes in the comments of a specific task. We have not yet thoroughly studied this factor. And I would also like to understand how setting these items affects sending messages about new comments on a specific task.