Updates to PDF not reflected on "Show on Card" Preview

%3CLINGO-SUB%20id%3D%22lingo-sub-1172194%22%20slang%3D%22en-US%22%3EUpdates%20to%20PDF%20not%20reflected%20on%20%22Show%20on%20Card%22%20Preview%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1172194%22%20slang%3D%22en-US%22%3E%3CP%3EAfter%20updating%20a%20PDF%20on%20my%20SP%20site%20that%20is%20linked%20to%20a%20Planner%20Card%2C%20and%20marked%20%22Show%20on%20Card%22%2C%20the%20changes%20to%20the%20documents%20are%20not%20reflected%20in%20the%20show%20on%20card%20preview.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20encountering%20this%20both%20on%20the%20iOS%20app%2C%20and%20desktop%20website.%20I%20have%20tried%20to%20remove%20and%20re-add%20the%20attachment%2C%20un-check%20and%20re-check%20show%20on%20card.%20I%20have%20waited%20approximately%2012%20hours%20since%20my%20last%20update%2C%20and%20the%20change%20is%20still%20not%20reflected%20in%20preview.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20was%20hoping%20that%20when%20I%20made%20changes%20to%20a%20pdf%2C%20I%20could%20save%20over%20the%20existing%20in%20SP%20Documents%20and%20the%20changes%20would%20reflect%20in%20Planner%2C%20instead%20of%20having%20to%20manually%20add%20a%20new%20attachment%20each%20time.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2032498%22%20slang%3D%22en-US%22%3ERe%3A%20Updates%20to%20PDF%20not%20reflected%20on%20%22Show%20on%20Card%22%20Preview%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2032498%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F406171%22%20target%3D%22_blank%22%3E%40JWhiteFEI%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThis%20seems%20to%20be%20a%20caching%20problem.%20I%20get%20updated%20previews%20as%20long%20as%20I%20use%20the%20browser's%20incognito%20mode%20or%20if%20I%20completely%20clear%20the%20cache.%20In%20Chrome%20you%20have%20to%20open%20the%20DevTools%20(F12)%20and%20then%20right-click%20on%20the%20regular%20refresh%20button%20next%20to%20the%20address%20bar%20and%20select%20the%20last%20option%20to%20clear%20the%20cache%20and%20do%20a%20full%20reload.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3ESee%20also%20this%20idea%20and%20vote%20on%20it%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fplanner.uservoice.com%2Fforums%2F330525-microsoft-planner-feedback-forum%2Fsuggestions%2F31184449-update-image-thumbnails-when-file-is-modified%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fplanner.uservoice.com%2Fforums%2F330525-microsoft-planner-feedback-forum%2Fsuggestions%2F31184449-update-image-thumbnails-when-file-is-modified%3C%2FA%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

After updating a PDF on my SP site that is linked to a Planner Card, and marked "Show on Card", the changes to the documents are not reflected in the show on card preview. 

 

I am encountering this both on the iOS app, and desktop website. I have tried to remove and re-add the attachment, un-check and re-check show on card. I have waited approximately 12 hours since my last update, and the change is still not reflected in preview.

 

I was hoping that when I made changes to a pdf, I could save over the existing in SP Documents and the changes would reflect in Planner, instead of having to manually add a new attachment each time.

1 Reply

@JWhiteFEI 

This seems to be a caching problem. I get updated previews as long as I use the browser's incognito mode or if I completely clear the cache. In Chrome you have to open the DevTools (F12) and then right-click on the regular refresh button next to the address bar and select the last option to clear the cache and do a full reload.

 

See also this idea and vote on it: https://planner.uservoice.com/forums/330525-microsoft-planner-feedback-forum/suggestions/31184449-up...