Task links to wrong attachment

%3CLINGO-SUB%20id%3D%22lingo-sub-860897%22%20slang%3D%22en-US%22%3ETask%20links%20to%20wrong%20attachment%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-860897%22%20slang%3D%22en-US%22%3E%3CP%3EWhen%20you%20upload%20a%20file%20to%20a%20task%20with%20a%20filename%20that%20already%20exists%20in%20the%20SharePoint%20folder%2C%20the%20Upload%20Process%20uploads%20the%20file%20and%20renames%20it%20with%20an%20incremental%20number%20at%20the%20end.%20BUT%20afterward%20links%20to%20the%20original%20file%20and%20not%20the%20newly%20uploaded%20attachment.%20Why%20rename%20it%20and%20yet%20link%20to%20the%20wrong%20one%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-860897%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EPlanner%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-860981%22%20slang%3D%22en-US%22%3ERe%3A%20Task%20links%20to%20wrong%20attachment%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-860981%22%20slang%3D%22en-US%22%3EIt%20seems%20to%20be%20a%20bug%20IMHO%2C%20best%20you%20can%20do%20here%20is%20to%20open%20a%20support%20ticket%20and%20report%20the%20same%20details%20you%20have%20provided%20here%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-861016%22%20slang%3D%22en-US%22%3ERE%3A%20Task%20links%20to%20wrong%20attachment%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-861016%22%20slang%3D%22en-US%22%3EOk%20will%20do%20that%2C%20but%20I'm%20just%20curious%20if%20no%20one%20ever%20noticed%20this%20before%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-861017%22%20slang%3D%22en-US%22%3ERe%3A%20Task%20links%20to%20wrong%20attachment%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-861017%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F60%22%20target%3D%22_blank%22%3E%40Juan%20Carlos%20Gonz%C3%A1lez%20Mart%C3%ADn%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EOk%20will%20do%20that%2C%20but%20I'm%20just%20curious%20if%20no%20one%20ever%20noticed%20this%20before%3F%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

When you upload a file to a task with a filename that already exists in the SharePoint folder, the Upload Process uploads the file and renames it with an incremental number at the end. BUT afterward links to the original file and not the newly uploaded attachment. Why rename it and yet link to the wrong one?

2 Replies
Highlighted
It seems to be a bug IMHO, best you can do here is to open a support ticket and report the same details you have provided here
Highlighted

@Juan Carlos González Martín 

 

Ok will do that, but I'm just curious if no one ever noticed this before?