Plans from Planner are not showing in Flow or third party Add-ins

Iron Contributor

I have seen several case where Plans from the Planner are not showing in the API. This means you will not be able to use Microsoft Flows for the Planner or use third party Add-ins with the Planner. I am not sure why this happens and I have only seen this on af few O365 tenants. It is a big prblem for these organisation and the Planner is simply not a useful tool.


Please advice? and it would be interesting to hear if any other have the same problem.

15 Replies

Experiencing the same thing.

Thank you Ron-el. We are currently working on identifying the problem and find a solution. I will keep you posted.
Looks like the limitation is based on the number of plans that can be displayed in the flow look-up for Planner plans. I got around this by grabbing the plan id from planner (found in the url) and pasting it directly in flow look-up. It resolves based on id anyway ;) hope this helps

Hi Ron-el thanks.

But in this case, I don't think it is due to a limitation of number of Plans. There might by such a limitation, but this is not what causing the error in this case. I am up on 7 organization (plus the one reported her) that have this error.  Several of them have less than five Plans. The error is realted to the API that don't returns  some or all Plans.


I got an update saying that the Planner team are aware of the issue and are working on pushing an update within a week or two. I hope this will solve the problem.



Got ya!

Were you able to use the work-around?
-- enter the planner id found in the url of the plan directyly into the planner trigger?


Hi Ron-el


We made a workaround while we are waiting for Microsoft to send out the update. The workarourd is for our Add-in that integrates to the Planner.  It works in most cases, but we have seen some tenants where it still gives problmes. But this means you can't use  this for Flow.


I am still hoping that Microsoft will push out an update asap.

Experiencing the same thing.

I have got an update from Microsoft saying they expect to start rolling out the fix next week.  Typically this sort of update will complete by the end of the week.


I therefore hope this problem will be sloved soon.


Should anyone still have this issue in two weeks time please posted it.

I am experiencing this same issue with the addition of IPlanner Pro, which I was using as a workaround, holding on to old Plans while not showing new plans.  It is very frustrating and equally renders this product nearly useless for daily use in a busy environment.

Hi Paul

Yes it is verf frustrating but we can expect the problem tp be solved this week. Microsoft is sending out the update that should handle this. Both iPlanner Pro, Microsoft Flow and other apps and add-in that are using the Planner should be fully functional by the end of the week.


You are welcome to give me a notice should it not be solved and I will contact Microsoft.

I also discovered that one cannot truly change the name of a plan.  Between the update and this, the issue is solved for me.

I was wondering if the updated solved your problem? I am asking because I still miss some of my plans in iPlanner Pro (the add on to Outlook that lets you create tasks out of an email). When I try to select a plan, I do get a list of plans (about 8 or so of them), but not the one I am looking for.

Hi Pavel


Yes this was solved a long time ago. Please try to reset the Add-in. You can do it from iPlanner menu. Sign in with your Office 365 account. If you want to be 100% sure that nothing is cached. Open your browser clear the browser cache, open your web mail and reset the add-in. You aer welcome to contact me directly if the problem continues. 




I am sorry to bump in this old thread, but the issue was not fully solved (at least for me). I have 5 plans in Planner. Only two of them were displaying in the "Create a Task" drop-down menu in Flow.


I cleaned Firefox cache. One additional plan is not displaying in the Flow pending menu. I cleaned the PC with Glary Utilities. None of the other 2 plans are displaying in the menu.


Please, let me know how to fix this Planner bug. Any advice is welcome.




Incoming Tasks to Distribute   Planner.pngCreate your flow   Microsoft Flow.png

Hello, the above issue is fixed. I had refreshed the browser and still the drop-down menu at Flow would not display all the Plans. However, I refreshed the browser 5 minutes later and now my 5 Plans are displaying on the Flow drop-down menu. Thank you.