Planner Tasks cannot be deleted or edited.

New Contributor

Hi,

After deleting a group to which a plan is assigned, two tasks remain in the task list. These can no longer be edited or deleted. Restoring the group was possible, but did not provide a solution.
The plan ID of the originally linked plan is different from that of the restored plan.

I have tried the following without success:

Delete in the Planner Chrome-Edge Browser Desktop /iPhone
Delete in Planner Safari Browser Desktop /iPhone
Delete in Teams Desktop /Web / Mobile
Delete in ToDo App

Error message:
"Only members of the Office 365 group can delete tasks. Technical details".


What else can I do to delete these tasks?

Regards Siggi

 

13 Replies

@Siegfried Baldauf 

 

same problem here

I did several plans for training. Deleted the plans with acknowledging task will also be deleted, but tasks did not delete and I cannot delete now. In the My Tasks, sort by plan … it has a column for each of the deleted plans saying "Former plan".   @tyger 

Same issue here...

I have restored the group that was deleted but I guess as the plan within the group is permanently deleted, the task is orphaned and inaccessible.

@Siegfried Baldauf 

I have the same problem. Trying to delete planner task through Microsoft Teams. Task show completed but cannot delete.

Is there a way to just reset the entire Planner and start over. I do not have that much in the planner now.  New license?  Any other ideas?  This is corporate system, but if that is the only solution, it would be doable.  I have instructed our IT manager to train everyone on if you are going to delete a plan, first delete all tasks.  Then delete plan.  I hope that works. We did not try it yet however.  @tyger 

@Siegfried Baldauf 

 

I have the same issue....yet to find a solution anywhere.

Yeah I guess it might work with a new license but For the moment I think when the plan is deleted permanently, there is no way to get access to the tasks in the plan. So unless something is done in the backend (e.g. through a software update) to at least let the owners access all the tasks, the problem could not be resolved. Meanwhile, as I see some posts from 2017 reporting the same problem, your proactive approach seems wise.

Our outstanding IT guy found the solution. I worked for us.  Try it. If it works, please post to other threads. I am not active here but only look occasionally.

He used the 12 steps from here:  https://planner.uservoice.com/forums/330525-microsoft-planner-feedback-forum/suggestions/14901261-bu...

 

Let me know if it works for you!

  @tyger 

@dlewis2849 

 

I have seen the post lately but as the plan is deleted I could not export it to excel to get the Task ID. However, now I tried to delete the task and it has gone for good :) I think the engineers at Microsoft played with the codes ;) So I think now the problem is fixed and there is no need to delete the tasks in advance if you need to delete the plan. 

 

But anyway, thank you for sharing the information.

@Siegfried Baldauf 

I don't know what was going on in the background, but after 48h I could suddenly delete the tasks today.

@dlewis2849 

 

This would be an outstanding solution IF the plan was not deleted. That is the whole issue, I don't see how that solution is to the same problem as here (the orphaned tasks from a "deleted" plan).

We did have this issue and the above solution did solve our orphaned tasks where the Plan was deleted.  I have not tried to recreate the orphan task issue since I did not want to see if it does work again at the risk of orphaned tasks.  Now we delete all tasks and then delete the plan.

 

Also, noted that if I change the plan name, the old and new tasks DO NOT list the new name in the MY TASKS list. So I have tried to be sure what I want to call the plan is thought out before starting.  Twice now I have had to start a new plan with the new name and slowly mover each task over.  The do the delete process I mentioned above.  Good Luck.   .@Kenzuk 

Hi,

Actually, if you open My Tasks in outlook, you can see the task that you created in microsoft team is there, and you can delete it from there.