Planner - disappearing comments - maybe Exchange delivery problem

Brass Contributor



since some days we experience issues with disseapering planner comments. 


We know that Planner "just" sends emails to the Group Mailbox.

We get an error in Exchange (Online Message Trace) when somebody sends a comment in into planner. It appears immendialty. After closing/opening the tasks the comment disappears. 

In Exchange Message Log we see the following messeage (Delivery Failed to the specific O365 Group Mailbox)


Aug 19, 2020 11:24:44 AM Drop Reason: [{LED=550 5.7.137 RESOLVER.GRP.ExpandBlockedByFeature; group expansion is blocked by the feature in the transport manifest for the message};{MSG=};{FQDN=};{IP=};{LRT=}]

All of our O365 Group Mailboxes are hidden from the Exchange Addresslist and it worked before without any problems. We have not changed any inside Exchange Online. If unhide the group in the Global Adresslist  it works but this is not an option. We do see that in some cases the error message appears but the comment is visible. 


Has anything changed. How to solve this. Any comments from the planner team ? 


Many Greetings






4 Replies



I have exact the same problem,

When adding a comment to the task the message disappears, after a minute 

I'm getting an outlook message: Undeliverable Comments

Message to <planner name> couldn't be delivered.


The Group <planner name> isn't set up to receive messages from <user emails address>.


Don't know what is going wrong but what I found is that the group does not except emails from you're domain. for example:

you're domain is and de planner email address is

so you're domain is an external email address 


What I did for the time being is in office 365 admin portal, go to groups, click on the group and on the tab settings enable "Allow external senders to email this group"


Hope I'll get an answer for this, cause I keep on getting messages from colleagues with this problem 


The "Allow external senders to email to this group" is already enabled. We have this only with 30% of the people for others it is working fine. We have a ticket openend within MS now. But as always it will take longer.




I've found the problem,

The email signature software that we were using was expired for some reason, 

We enabled it again and the problem was solved.

So, what was the solution..? Running into the same error message.