New UI changes rolling out in Planner

Valued Contributor

Hi All,

Today Microsoft has started rolling out its refreshed UI in Planner which makes the use of Planner awesome! Below are the screenshots which explains the changes. Actions from Plans card viewActions from Plans card viewPlanner hubPlanner hubNew plan creationNew plan creationAttachmentsAttachmentsPlanner5.png

42 Replies


We have the same Problem whit sessions. Also for example the sho decription on card button gets lost on some plans.

We open a ticket since Friday. No solution yet from MS (really MS tomorrow ONE WEEK without our data in description)!

So it is not possible to make a backup from Planner and Microsoft kills our data (Description field).

Thank you MS!

Is this the new Cloud based world?

I am really sad....


Are you on macOS too? My colleagues use Windows and they don't have all the issues I mentioned, Planner works fine for them :thinking_face:
Windows. Probs with Chrome, Firefox, Edge.
You can see it on the youtube video a few articles earlier.

I have same expired message - Windows 10/Firefox - very irritating :(

The new UI has made Planner unusable with Safari on macOS or iOS.


I can no longer scroll vertically through the cards in any bucket.  I'm left being able to view the top few cards in any given bucket and that's it.


Problem doesn't seem to exist with Chrome on the Mac.

In my own experience, Planner never worked well with Safari, that's why I used to open it in Chrome. It was fine, until last week's update made it really buggy on any browser on my Mac...

Same problem here with "Your session has expired, please sign in again" message.

Hi Klaus,

I confirm, we have the same issue on our side.

I encountered a new issue yesterday: I can no longer assign cards to anyone, I now get a weird message telling me that "your item or storage limit has been exceeded."


Screen Shot 2017-08-01 at 16.15.20.png

I'm seeing this on Sarafi, Chrome and Firefox on my Mac, and refreshing the page doesn't help. None of my colleagues have been affected by this so far.

Am I the only one to see this?

Is this may be due to this limitation?


But recently noticed that MSFT has increated these limits to 300 assigned tasks per user and 2500 created tasks for an user. Not sure if you have reached those limits. You can try deleting come of the completed tasks assigned to you. 

No, that's not the problem.
I think the GUI change has erased the description field. Microsoft has no backup and so they can't get the data back for us. The error that kills the description field still exists. If you fill the description close the task and select the show on card checkbox on and off the data loss happen again...

Some specifics we've noticed: This scrolling issue is on the O365 Web Application when using a Safari or Chrome browser on an IOS system. This is an issue on the board when a bucket has more than enough tasks to cause scrolling. We don't have an issue when using the "chart" panel/page/view. We don't have this issue on any Windows 10 browsers (Edge/FF/IE/Chrome) at the moment.

This issue has been resolved
Mat K. - Which issue were you replying to? My IOS/IPad Safari scrolling issue on the Buckets view is not resolved just yet on my org.

Nothing resolved. We don't get our data back, since last update in all browsers (Edge, Firefox, Chrome) we get session time out's and counters for tasks etc are missing!


Microsoft should change the programming team very quick. This people can't mange quality!


It's a shame....

Is there an ETA when the regression of the scrolling bars will be fixed?

It's nearly impossible to use my boards appropriately atm without them.

I am experiencing the "your session has expired" every few minutes on windows 10 on chrome.


I just started using office365 a month ago with very high expectations, based on the functionality promised by the MS products. HUGELY disappointed with everything Microsoft based on this month's experience. It feels like MS is doing everything possible to confuse the hell out me as a user, from duplicate product names to quirky sign-in requirements, to buggy products that simply don't do what they claim to do!

Have you tried this from Edge? I am using it without any issues. If the issue still persists you need to raise the Support ticket.

@Santhosh Balakrishnan wrote:
Have you tried this from Edge? I am using it without any issues. If the issue still persists you need to raise the Support ticket.

If your answer to this issue is "use edge" that's a terrible response.  Edge is available in Windows 10 only, an a "web enabled app" should not be tied to a single browse



today we have also colleagues with Planner timeout errors.

They use Win 7 and IE11 or Firefox.

Is there a workaround or a solution to solve this issue?