Bug with the link generated by One NOte and Planner (maybe others)

Copper Contributor

When I paste a OneNote URL into a Task Link it says that the URL is invalid. Same problem with a link to another Task. Very annoying bug

13 Replies
How are you adding the link to the Task? In a Task comment?

@Vincent Perron, this is the validation issue with Microsoft latest update. I have tried adding the same OneNote / Planner task link via Graph API and it linked to the task successfully. 


@Joanna Parkhurst, can you please help to get this fixed. This limits the planner usage in many ways. 

These are the exact steps:

- right click on a One Note page and Select "Copy Link"

- Open a Task and Click "Add Attachment"

- Select "Add Link"

- Paste the previously copied link

- Error Message : "Please enter a valid url"

Have you tried to use the link you can get in ODFB in the Share section? I have just used the link generated for one of my OneNotes in a Planner Task with no problems

Links from One Drive seem to work. The point is that you don't want to link the entire One Note, you want to link to a specific Page. And what is the point of having a copy link option if the link you copied is unusable ?


By the way I think those links are problematic for other third party applications. I know they dont work in JIRA either. 

Sorry for the typo, I mean the link you can get in the Share section in OneNote

I add the link as an attachment to the Planner task. For example, if I go to another Planner board and obtain the link to it and then paste it as an attachment to the other task in the other board, I get the stated error. I've also narrowed down the problem to the use of the ampersand symbol in a URL. That's why it complains. Remove the ampersand and the Planner task attachment link screen likes it, but obviously now the URL won't work.

I found a weird solution that worked for me. For example, I start with, 




Obviously, the "https://" prefix is already provided by Planner. I substituted my private info. But it complains when I give it the above, saying, "Please enter a valid url", leaving the Save button disabled. When I switch it to this:




....now the Planner error goes away and the Save button becomes enabled. If I click the link in the saved Planner task now, it opens the right board up and the URL I see in the address bar ends up being:




Notice the ampersands are put back in place and everything works!


It works for the links to Tasks. But not for the link to OnePages. I hope they will fix that bug soon... 

Note that the workaround where I switch an ampersand for a plus sign does not render every URL valid. Although Planner will allow them to save and this worked for links to other Planner boards, some other manipulated URLs to other sites fail.

Someone else has reported the bug at Ampersand URL Bug. I suggest we all vote it up.

Same problem. Thanks for starting the conversation


Very limiting since Planner doesn't have any other way to add attachments except through links.

I have this problem too.

Slightly annoying as previously linking to OneNote pages which have the ampersand sign worked fine.

I have upvoted the bug. Hopefully it gets resolved soon as we are trying to use the MS suite, but things like this create quite an annoyance.