SOLVED

Can't register for Microsoft Hardware Developer Program

Copper Contributor

When trying to sign in to register for the windows Hardware developer program, It throws an error saying that my account isn't a Microsoft account but it very much is. In fact, it's an Entra ID Global Administrator account. How do I fix this or get Microsoft to fix this.

25 Replies
Can confirm we managed to start the process, thank you all for keeping this alive, it seems to be working again

@Claudio_Granatiero GREAT NEWS! Thank you so much for coming back and posting in the string.

 

Much appreciated. 

@Claudio_Granatiero Hello,

 

the Registration process is working again. But the Final Registration failes with an error code:

tried serveral times the during the last week.

error_signup.jpg

Hi,
sorry to hear that. My registration has worked and I was able to successfully submit a binary that has been then signed. Did you try to contact the Support with that error?

@Claudio_Granatiero okay I'll contact support, and see if the issue gets fixed. Thanks for your quick reply

 

PS: I could upload my signed binary just fine, and it doesn't prompt me do do so again. jumps right to the last page to agree all terms and conditions, then fails.

After reaching the final step of registration, an error occurs, rendering the service unusable indefinitely. We have already spent a month on this issue, and it remains unresolved. Our company's product launch is delayed due to this problem. Is there any alternative solution available?

 

We contacted the support team a month ago, but they have been of no help. Besides receiving an email every other day stating that the issue is being processed, there has been no progress. We spent thousands of dollars on purchasing the certificate, but we are unable to use it due to submission issues.