SOLVED
Home

Re-request password

%3CLINGO-SUB%20id%3D%22lingo-sub-332891%22%20slang%3D%22en-US%22%3ERe-request%20password%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-332891%22%20slang%3D%22en-US%22%3E%3CP%3EGood%20day.%20I%20periodically%20have%20a%20problem%20with%20outlook.%20I%20read%20a%20lot%20of%20forums%20on%20the%20Internet%20and%20tips%2C%20but%20nothing%20helped%20me.%20We%20have%20several%20domain%20controllers%20in%20our%20organization.%20Password%20synchronization%20occurs%20once%20every%2030%20minutes.%20On%20the%20domain%20controller%20there%20is%20a%20policy%20for%20users%20to%20change%20the%20password%20once%20a%20month.%20If%20a%20user%20changes%20the%20password%2C%20it%20takes%2030-40%20minutes%20for%20him%20to%20go%20into%20all%20Office365%20programs%20except%20outlook.%20The%20program%20constantly%20asks%20for%20a%20password.%20What%20I%20have%20tried%3A%3CBR%20%2F%3E1)%20Reboot%20PC%3CBR%20%2F%3E2)%20rundll32.exe%20keymgr.dll%2C%20KRShowKeyMgr%20deleted%20all%20passwords%3CBR%20%2F%3E3)%20resetting%20the%20activation%20of%20office365%3C%2FP%3E%3CP%3EWhen%20entering%20the%20password%2C%20there%20are%20no%20errors%2C%20it%20accepts%20it%20but%20then%20immediately%20requests%20the%20password%20again.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-332891%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Epassword%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Epassword%20sync%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-335178%22%20slang%3D%22en-US%22%3ERe%3A%20Re-request%20password%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-335178%22%20slang%3D%22en-US%22%3E%3CP%3EHmmm%2C%20and%20here%20I%20though%20autodiscover%20will%20trigger%20a%20basic%20auth%20prompt.%20Lesson%20learned!%20And%20glad%20your%20issue%20is%20solved%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-335044%22%20slang%3D%22en-US%22%3ERe%3A%20Re-request%20password%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-335044%22%20slang%3D%22en-US%22%3E%3CBR%20%2F%3EProblem%20solved.%20Added%20parameters%20to%20the%20registry.%3CBR%20%2F%3EHKEY_CURRENT_USER%20%5C%20Software%20%5C%20Microsoft%20%5C%20Office%20%5C%20x.0%20%5C%20Outlook%20%5C%20AutoDiscover%3A%3CBR%20%2F%3EPreferLocalXML%200%3CBR%20%2F%3EExcludeHttpRedirect%200.%3CBR%20%2F%3EExcludeHttpsAutoDiscoverDomain%201.%3CBR%20%2F%3EExcludeHttpsRootDomain%201.%3CBR%20%2F%3EExcludeScpLookup%20and%20value%201.%3CBR%20%2F%3E6.%20Key%20type%20DWORD-32%20with%20the%20name%20ExcludeSrvRecord%20and%20value%201.%3CBR%20%2F%3E7.%20Key%20type%20DWORD-32%20with%20the%20name%20ExcludeLastKnownGoodURL%20and%20value%201.%3CBR%20%2F%3E8.%20A%20DWORD-32%20key%20with%20the%20name%20ExcludeExplicitO365Endpoint%20and%20a%20value%20of%201.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-334932%22%20slang%3D%22en-US%22%3ERe%3A%20Re-request%20password%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-334932%22%20slang%3D%22en-US%22%3E%3CP%3EWell%20I'm%20out%20of%20idea.%20Which%20Outlook%20build%20is%20that%3F%20And%20have%20you%20opened%20a%20support%20case%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-334921%22%20slang%3D%22en-US%22%3ERe%3A%20Re-request%20password%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-334921%22%20slang%3D%22en-US%22%3E%3CP%3EWhen%20I%20enter%20the%20portal%20with%20passwords%2C%20everything%20is%20fine.%20If%20I%20try%20to%20go%20to%20Teams%20(Skype)%20on%20my%20computer%20-%20everything%20is%20fine.%20The%20problem%20is%20only%20when%20I%20enter%20outlook%20-%20the%20system%20accepts%20the%20password%2C%20but%20after%201-2%20seconds%20it%20writes%2C%20enter%20the%20password%20again.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-334497%22%20slang%3D%22en-US%22%3ERe%3A%20Re-request%20password%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-334497%22%20slang%3D%22en-US%22%3E%3CP%3EOK%2C%20so%20this%20is%20the%20correct%20prompt%20when%20you%20use%20Office%20clients%20with%20Modern%20auth%20enabled%2C%20that%20part%20is%20good.%20However%2C%20if%20you%20are%20getting%20an%20error%20message%20that%20the%20password%20is%20not%20correct%2C%20this%20suggest%20there%20is%20some%20issue%20with%20the%20password%20sync%2C%20so%20I'd%20recommend%20going%20over%20the%20troubleshooting%20article%3A%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Factive-directory%2Fhybrid%2Ftshoot-connect-password-hash-synchronization%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Factive-directory%2Fhybrid%2Ftshoot-connect-password-hash-synchronization%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EOr%20simply%20try%20to%20login%20with%20the%20changed%20password%20directly%20at%20the%20O365%20portal.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-334074%22%20slang%3D%22en-US%22%3ERe%3A%20Re-request%20password%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-334074%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20345px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F72591iA171D7DF61C0A056%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22e444933e-5c4a-467d-a45d-dc88e267cf1b.jpg%22%20title%3D%22e444933e-5c4a-467d-a45d-dc88e267cf1b.jpg%22%20%2F%3E%3C%2FSPAN%3E%3CSPAN%3EErrors%20that%20the%20password%20is%20not%20correct%20-%20does%20not%20show.%20I%20enter%20the%20password%2C%20the%20system%20accepts%20it%2C%20after%201-2%20seconds%20enter%20the%20password.%20The%20window%20has%20already%20written%20user%20account.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-333603%22%20slang%3D%22en-US%22%3ERe%3A%20Re-request%20password%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-333603%22%20slang%3D%22en-US%22%3E%3CP%3EAccepts%20the%20password%20is%20generally%20the%20opposite%20of%20asks%20for%20password%20again%20%3A)%3C%2Fimg%3E%20Does%20it%20show%20the%20account%20connected%20in%20the%20status%20bar%3F%20What%20does%20the%20prompt%20look%20like%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-333425%22%20slang%3D%22en-US%22%3ERe%3A%20Re-request%20password%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-333425%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3E2FA%20-%20no%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20enter%20the%20password%2C%20the%20system%20accepts%20it%20-%20once%20again%20asks%20for%20the%20password%20-%20and%20so%20constantly.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-333076%22%20slang%3D%22en-US%22%3ERe%3A%20Re-request%20password%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-333076%22%20slang%3D%22en-US%22%3E%3CP%3EWhat%20does%20the%20prompt%20look%20like%3F%20And%20are%20you%20using%20any%20form%20of%202FA%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Good day. I periodically have a problem with outlook. I read a lot of forums on the Internet and tips, but nothing helped me. We have several domain controllers in our organization. Password synchronization occurs once every 30 minutes. On the domain controller there is a policy for users to change the password once a month. If a user changes the password, it takes 30-40 minutes for him to go into all Office365 programs except outlook. The program constantly asks for a password. What I have tried:
1) Reboot PC
2) rundll32.exe keymgr.dll, KRShowKeyMgr deleted all passwords
3) resetting the activation of office365

When entering the password, there are no errors, it accepts it but then immediately requests the password again.

9 Replies
Highlighted

What does the prompt look like? And are you using any form of 2FA?

Highlighted

2FA - no

 

I enter the password, the system accepts it - once again asks for the password - and so constantly.

Highlighted

Accepts the password is generally the opposite of asks for password again :) Does it show the account connected in the status bar? What does the prompt look like?

Highlighted

e444933e-5c4a-467d-a45d-dc88e267cf1b.jpgErrors that the password is not correct - does not show. I enter the password, the system accepts it, after 1-2 seconds enter the password. The window has already written user account.

Highlighted

OK, so this is the correct prompt when you use Office clients with Modern auth enabled, that part is good. However, if you are getting an error message that the password is not correct, this suggest there is some issue with the password sync, so I'd recommend going over the troubleshooting article: https://docs.microsoft.com/en-us/azure/active-directory/hybrid/tshoot-connect-password-hash-synchron...

 

Or simply try to login with the changed password directly at the O365 portal.

Highlighted

When I enter the portal with passwords, everything is fine. If I try to go to Teams (Skype) on my computer - everything is fine. The problem is only when I enter outlook - the system accepts the password, but after 1-2 seconds it writes, enter the password again.

Highlighted

Well I'm out of idea. Which Outlook build is that? And have you opened a support case?

Highlighted
Solution

Problem solved. Added parameters to the registry.
HKEY_CURRENT_USER \ Software \ Microsoft \ Office \ x.0 \ Outlook \ AutoDiscover:
PreferLocalXML 0
ExcludeHttpRedirect 0.
ExcludeHttpsAutoDiscoverDomain 1.
ExcludeHttpsRootDomain 1.
ExcludeScpLookup and value 1.
6. Key type DWORD-32 with the name ExcludeSrvRecord and value 1.
7. Key type DWORD-32 with the name ExcludeLastKnownGoodURL and value 1.
8. A DWORD-32 key with the name ExcludeExplicitO365Endpoint and a value of 1.
Highlighted

Hmmm, and here I though autodiscover will trigger a basic auth prompt. Lesson learned! And glad your issue is solved :)