Problems during encryption of mail

Copper Contributor

Hi there

We have a problem with encryption of mails. We are using the danish NemID which is a S/Mime method. A couple of weeks ago, we created the contact with the certificate and was able to send encrypted. 

But today we tried again, and it failed. 

We tried from another user, but the same contact.. and the same user but another contact, and it worked. 

We tried deleting the contact and recreating it, restarting the computer but no luck.. My best guess is, that we need to delete the certificate further down before we can reinstall it. 

7 Replies

@Børge Holse Hello, difficult to say with the attached information. How about deleting the contact, have the contact sending a new signed email to the user, import the certificate/save the contact and try setting it up again.


*edit* had a look at the attached photo. That shows when you do not have your recipient’s public key.

Is the public key the same as the certificate in the contact? Then we have it

@Børge Holse Hello again and sorry for the late reply. Yes, I did mean that. The contact has to send a signed email message to your user to have him/her save the contact and the cert/public key for the encryption to work. But I get the feeling you already know this.


Another thing that could be causing the issue, as you've done the process all over again, could be that when you send an encrypted email to a recipient the recipient's certificate/public key is used to encrypt it. If the email address of the contact doesn't match the email address in the recipient's certificate, you'll also get the message you attached.


I just did a search and found a page that actually describes it. Don't be alarmed by the old "applies to", it should still be possible if you use the appropriate key.


Hope it helps!

@ChristianBergstrom Thanks for the answer.. I will try this on monday when the employees are back. 



Hey! Any luck with the issue?

@ChristianBergstrom  Sorry for the late reply the employee had a couple of days off so we tried it today.. 

No luck with the link. 


You can see in sikker2.png that I added the registry key.. I emptied the outlook cache and started outlook. 

I started "certmgr" and found 2 certificates for the receiver under "Other people" and then I deleted the contact with the certificate and deleted the certificates from certmgr. Restarted outlook, reimported the contact with the certificate and checked that only one certificate installed in certmgr. 


But still the same error. 

@Børge Holse Hello! No worries. And the mail address of the contact match the email address in the recipient's certificate?


If all looks OK perhaps you need to raise a ticket with MS support.