Home

Outlook VBA: "Component not correctly registered" and user forms

%3CLINGO-SUB%20id%3D%22lingo-sub-655463%22%20slang%3D%22en-US%22%3EOutlook%20VBA%3A%20%22Component%20not%20correctly%20registered%22%20and%20user%20forms%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-655463%22%20slang%3D%22en-US%22%3E%3CP%3EDear%20experts%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20problem%20quite%20similar%20to%20that%20described%20in%20a%20posting%20from%202018%20in%20the%20Excel%20community%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FExcel%2FCan-t-add-User-Form-in-VBA-project%2Fm-p%2F153619%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FExcel%2FCan-t-add-User-Form-in-VBA-project%2Fm-p%2F153619%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAfter%20a%20hardware%20change%2C%20I%20tried%20to%20use%20my%20makros%20and%20tools%20which%20I%20programmed%20using%20Office%202017%20in%20Office%20365.%20It%20works%20in%20Word%2C%20in%20Excel%20and%20in%20Access%20-%20but%20it%20doesn't%20work%20in%20Outlook.%20Whenever%20I%20try%20to%20insert%20a%20user%20form%2C%20I%20get%20the%20error%20message%20mentioned%20in%20the%20subject.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20opened%20a%20new%20discussion%20as%20my%20situation%20(works%20for%20most%20of%20the%20office%20programs%20but%20does%20not%20work%20for%20one)%20is%20slightly%20different%20and%20Outlook%20is%20concerned.%20All%20the%20libraries%20mentioned%20in%20similar%20cases%20also%20in%20other%20communities%20are%20installed%20correctly%20(just%20to%20be%20sure%20not%20to%20miss%20something%2C%20I%20add%20some%20screenshots).%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20hints%20or%20new%20information%20since%202018%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EKind%20regards%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFranz%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-655463%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOutlook%20for%20Windows%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
fst-at
Visitor

Dear experts,

 

I have a problem quite similar to that described in a posting from 2018 in the Excel community: https://techcommunity.microsoft.com/t5/Excel/Can-t-add-User-Form-in-VBA-project/m-p/153619

 

After a hardware change, I tried to use my makros and tools which I programmed using Office 2017 in Office 365. It works in Word, in Excel and in Access - but it doesn't work in Outlook. Whenever I try to insert a user form, I get the error message mentioned in the subject.

 

I opened a new discussion as my situation (works for most of the office programs but does not work for one) is slightly different and Outlook is concerned. All the libraries mentioned in similar cases also in other communities are installed correctly (just to be sure not to miss something, I add some screenshots).  

 

Any hints or new information since 2018?

 

Kind regards,

 

Franz

 

 

Related Conversations
Upload feature not available
sarahtherapist in Microsoft Forms on
7 Replies
Ideas requested
KDavidP1987 in SharePoint on
0 Replies
Embed microsoft form within the email
Sumaira370 in Microsoft Forms on
2 Replies
Ability to send document to responder
Brad0025 in Microsoft Forms on
1 Replies