Outlook To Recepients Display Name Mismatch with Users email address

%3CLINGO-SUB%20id%3D%22lingo-sub-1337343%22%20slang%3D%22en-US%22%3EOutlook%20To%20Recepients%20Display%20Name%20Mismatch%20with%20Users%20email%20address%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1337343%22%20slang%3D%22en-US%22%3E%3CP%3Efor%20some%20staff%20the%20email%20address%20returned%20from%20Auto%20Complete%20Suggections%2C%20the%20Display%20Name%20is%20is%20different%20to%20the%20email%20address%2CBut%20regarding%20the%20Mismatch%20of%20the%20name%20and%20email%20the%20incorrect%20displayed%20name%20cannot%20be%20found%20for%20any%26nbsp%3B%20user%20in%20exchange%202016%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20are%20using%20outlook%20version%26nbsp%3B16.0.11929.20436%20Semi%20annual%20Channel%26nbsp%3B%3C%2FP%3E%3CP%3EExchange%202016%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20below%20article%20MS%20has%20conformed%20it%20was%20a%20bug%20and%20fixed%20in%20older%20version%20of%20outlook%20wanted%20to%20check%20if%20the%20same%20has%20reappeared%20again%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fanswers.microsoft.com%2Fen-us%2Fmsoffice%2Fforum%2Fall%2Foutlook-2016-to-field-display-name-mismatch-bug%2Fa0fcbfb8-88c2-401a-8b47-3bf1da1d6f23%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fanswers.microsoft.com%2Fen-us%2Fmsoffice%2Fforum%2Fall%2Foutlook-2016-to-field-display-name-mismatch-bug%2Fa0fcbfb8-88c2-401a-8b47-3bf1da1d6f23%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPlease%20provide%20your%20sujjections%20and%20the%20possible%20permanent%20solutions%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1337343%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExchange%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOutlook%20Customer%20Manager%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOutlook%20for%20Windows%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1337981%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20To%20Recepients%20Display%20Name%20Mismatch%20with%20Users%20email%20address%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1337981%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F264365%22%20target%3D%22_blank%22%3E%40Niroshan_Ezra%3C%2FA%3E%26nbsp%3BHello%2C%20has%20this%20suddenly%20appeared%3F%20Are%20the%20changes%20made%20recently%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFirst%20of%20all%20I%20just%20want%20to%20ask%20if%20you've%20deleted%20the%20Auto-Complete%20Cache%20on%20the%20clients%20and%2For%20searched%20for%20the%20users%20directly%20in%20the%20GAL%20to%20verify%3F%20Have%20you%20manually%20started%20a%20'download%20of%20address%20book'%20in%20an%20Outlook%20client%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhat's%20common%20is%20that%20Exchange%20generates%20the%20OAB%20every%208%20hours%20and%20then%20you%20have%20the%20Outlook%20client(s)%20updating%20the%20OAB%20every%2024%20hours%20(if%20left%20constantly%20running).%20So%2C%20if%20not%20pushing%20this%20manually%20it's%20a%20case%20of%20waiting%20for%20it%20to%20synchronize%20properly.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1338819%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20To%20Recepients%20Display%20Name%20Mismatch%20with%20Users%20email%20address%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1338819%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F551905%22%20target%3D%22_blank%22%3E%40bec064%3C%2FA%3E%26nbsp%3B%20%26nbsp%3Bthank%20you%20for%20the%20reply%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ethis%20has%20has%20been%20happening%20for%20the%20past%206%20to%208%20months%20time%20since%20we%20moved%20to%20exchange%202016%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ebut%20this%20is%20not%20for%20all%20staff%26nbsp%3B%20only%20a%20very%20few%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ei%20tried%20to%20manually%20downlaod%20the%20gal%20no%20luck%2C%20also%20when%20searched%20the%20display%20name%20there%20is%20no%20such%20entry%20in%20gal%2C%26nbsp%3B%20but%20the%20email%20addres%20is%20available%20whihc%20shows%20the%20correct%20user%20in%20gal%2C%20how%20it%20should%20be%2C%20aslo%20clearing%20the%20auto%20complete%20fixes%20for%20the%20time%20being%20once%20the%20nick%20name%20cache%20buiilds%20its%20shows%20up%20the%20incorrect%26nbsp%3B%20display%20name%20for%20the%20email%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1339157%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20To%20Recepients%20Display%20Name%20Mismatch%20with%20Users%20email%20address%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1339157%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F449732%22%20target%3D%22_blank%22%3E%40NiroEzra%3C%2FA%3E%26nbsp%3BHello%20again%2C%20so%20this%20has%20been%20happening%20for%20the%20past%206-8%20months%2C%20but%20only%20a%20few%20users%20are%20having%20this%20issue%3F%20As%20you%20believe%20this%20could%20be%20a%20result%20of%20a%20previous%20Outlook%20bug%20I%20must%20ask%20what%20you've%20done%20troubleshooting%20this%20from%20an%20Outlook%20client%20perspective%3F%20Meaning%20the%20build%2C%20see%20below.%20(by%20this%20I%20am%20assuming%20your%20Exchange%20configuration%20is%20OK).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20must%20say%20I%20am%20a%20bit%20confused%20regarding%20the%20build%20number.%20I%20only%20get%20one%20hit%20under%20the%20release%20notes%20for%20the%20Update%20Channels%20(the%20one%20you're%20referring%20to)%20and%20that's%20the%20'Semi-Annual%20Channel%20Targeted'%2C%20version%201908%20build%2011929.%3CSTRONG%3E20436%3C%2FSTRONG%3E%26nbsp%3Breleased%20in%20November%202019.%20How%20come%20you're%20using%20this%3F%20The%20first%20version%20of%201908%20for%20the%20Semi-Annual%20Channel%20was%20build%2011929.%3CSTRONG%3E20562%3C%2FSTRONG%3E.%20The%20build%20you're%20using%20was%20actually%20updated%20only%2010%20days%20after%20it's%20release.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMy%20recommendation%20would%20be%20to%20install%20an%20updated%20build%20on%20one%20of%20the%20affected%20users%20and%20see%20what%20happens.%20Best%20practice%20from%20my%20experience%20is%20to%20separate%20the%20update%20channels.%20For%20example%2C%20early%20adopters%20on%20the%20Monthly%20Channel%2C%20pilot%20users%20on%20the%20Semi-Annual%20Targeted%20and%20the%20rest%20on%20the%20default%20Semi-Annual%20Channel.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20a%20newer%20build%20does%20not%20solve%20the%20issue%20I%20suggest%20you%20raise%20a%20ticket%20with%20Microsoft%20Support.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1353450%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20To%20Recepients%20Display%20Name%20Mismatch%20with%20Users%20email%20address%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1353450%22%20slang%3D%22en-US%22%3E%3CP%3EOnly%20Option%20is%20to%20unlink%20the%26nbsp%3B%20incorrect%26nbsp%3B%20contacts%2C%20manually%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

for some staff the email address returned from Auto Complete Suggections, the Display Name is is different to the email address,But regarding the Mismatch of the name and email the incorrect displayed name cannot be found for any  user in exchange 2016,

 

We are using outlook version 16.0.11929.20436 Semi annual Channel 

Exchange 2016 

 

The below article MS has conformed it was a bug and fixed in older version of outlook wanted to check if the same has reappeared again 

https://answers.microsoft.com/en-us/msoffice/forum/all/outlook-2016-to-field-display-name-mismatch-b... 

 

Please provide your sujjections and the possible permanent solutions 

4 Replies

@Niroshan_Ezra Hello, has this suddenly appeared? Are the changes made recently?

 

First of all I just want to ask if you've deleted the Auto-Complete Cache on the clients and/or searched for the users directly in the GAL to verify? Have you manually started a 'download of address book' in an Outlook client?

 

What's common is that Exchange generates the OAB every 8 hours and then you have the Outlook client(s) updating the OAB every 24 hours (if left constantly running). So, if not pushing this manually it's a case of waiting for it to synchronize properly.

@ChristianBergstrom   thank you for the reply 

 

this has has been happening for the past 6 to 8 months time since we moved to exchange 2016,

 

but this is not for all staff  only a very few,

 

i tried to manually downlaod the gal no luck, also when searched the display name there is no such entry in gal,  but the email addres is available whihc shows the correct user in gal, how it should be, aslo clearing the auto complete fixes for the time being once the nick name cache buiilds its shows up the incorrect  display name for the email

 

@NiroEzra Hello again, so this has been happening for the past 6-8 months, but only a few users are having this issue? As you believe this could be a result of a previous Outlook bug I must ask what you've done troubleshooting this from an Outlook client perspective? Meaning the build, see below. (by this I am assuming your Exchange configuration is OK).

 

I must say I am a bit confused regarding the build number. I only get one hit under the release notes for the Update Channels (the one you're referring to) and that's the 'Semi-Annual Channel Targeted', version 1908 build 11929.20436 released in November 2019. How come you're using this? The first version of 1908 for the Semi-Annual Channel was build 11929.20562. The build you're using was actually updated only 10 days after it's release.

 

My recommendation would be to install an updated build on one of the affected users and see what happens. Best practice from my experience is to separate the update channels. For example, early adopters on the Monthly Channel, pilot users on the Semi-Annual Targeted and the rest on the default Semi-Annual Channel.

 

If a newer build does not solve the issue I suggest you raise a ticket with Microsoft Support.

Only Option is to unlink the  incorrect  contacts, manually