Outlook Search not showing results on MAC M1 Pro

New Contributor

Hello, I upgrade to a MAC M1 Pro and the search feature does not return any results. I followed the directions for re indexing and no luck. The MAC OS is: Monterey 12.1 (21C52) & the Outlook for Mac version is: 16.56  Your help will be highly appreciated! Happy New Year to all. 

24 Replies
Search in Outlook for Mac is the most broken thing. These workarounds might get it to work for a while, but then it will eventually stop working again. I gave up on getting it to work permanently and switched to other clients.

@vanduker thanks for confirming that it is indeed broken! I am on an exchange server hence I cant use the new outlook... 

@Emilio_Colon 

 

Maybe it saves someone else a hassle.  None of the legacy fixes do anything except waste time.    

 

For me I have the new M1 that does not work but my 2014 MBP with same MacOS and Outlook works fine.  

 

I am able to use the "New Outlook" so search does work but the interface stinks.  I've resorted to use of native Mail for search functions.  

 

Good luck.  Is still broken in current MacOS beta 12.2 and current Outlook beta.

@Emilio_Colon it worked fine until two weeks ago, now its broke and nothing helps

-the workarounds from various fora, even with in between "close and restart outlook"

-external re indexing tool for Spotlight

-re-install of outlook

all returns nothing. 

I need to use outlook for my work, so resorting to other clients simply is not possible. 

 

Really frustrating, all in all. 

Kind Regards, 

Freek Peters. 

 

@FreekpetersThis has been frustrating since I got my new Mac M1 Air in mid-December. If I use the new Outlook interface it can work, but the interface is frustrating in other ways. Where is the fix?

dunno @Jenni_jle7 . My next step is to move away from Outlook with my private mail to the likes of Thunderbird (never an issue) so only the business exchange mail stays on outlook. Then the "new version of outlook" function might be able to fix the issue. Getting desperate here. If that fails as well i am considering a standard windows computer :(

 

My mac is still intel based, so the problem is wider than M1 macs. 

 

cheers

freek

@Emilio_Colon I've been having the same issue and tried everything I could think of, finally contacting Microsoft support, who suggested most of the same things, then said to reinstall, which I did. Nothing worked.

 

My question is simple: is search in original mode Outlook working for anyone on a new MacBook Pro? (Versions: M1 Pro, Outlook 16.56, and MacOS Monterey 12.1)

 

If not, then we can stop wasting time and wait for a fix from Microsoft and Apple. 

https://support.microsoft.com/en-us/office/search-in-outlook-for-mac-returns-no-results-after-instal... 

 

From Microsoft Customer Support:

We have noticed users reporting search related issue in Outlook after updating to latest Mac OS version 12.1. This is documented in our article:

 
 
Also, we have received an information as to the fix is rolled out in one of our Insider Fast ring (beta version) of Outlook for Mac and we are assuming that this feature will soon be release to all the users in the upcoming updates. I would recommend you to wait for fix to roll out to the production build, as Insider fast is not a stable build.
 
Note: Office Insider is a preview program for Office subscribers. On Insiders you will be the first to receive the latest features/upgrades, thus helping to identify issues and provide feedback to help make Office great. However, signing up for Insiders would result in a few issues with certain features, as the features released are new.

@Emilio_Colon I'm happy to report the problem has been fixed in 16.57 (22011101). I've verified and it is working well.

Thank you, I checked last night after the update and the search is now working again!

I am on 12.1 with the 16.57 update installed and search is still not working.

 

I should add that I have tried every step that every blog recommends when you google the problem.

Can you double check that the 16.57 is 22011101? There may be more than one build of 16.57.

If you are on 22011101 I would give another go of adding "Macintosh HD" to the Privacy exclusions in Spotlight and then remove it. That will rebuild the index.

I hope that fixes it. I just know a lot of people like me have seen 22011101.

Yep, just verified I'm on 16.57 (22011101) and search will not work.

 

Also, did the Spotlight trick you mentioned. No luck yet but I'll give it a few...

If putting Mac HD into Privacy exclusions in Spotlight and taking it out again doesn't fix it, consider forcing Outlook to rebuild the Outlook database. I deleted all of the sql lite files in ~/Library/Group Containers/UBF8T346G9.Office/Outlook/Outlook 15 Profiles/Main Profile/Data which didn't work until the new update of Outlook. (That step had fixed a search failure on a 2017 MacBook Pro.)

Thanks for the suggestions, still no luck. I also just noticed tonight that searching contacts isn't working either.

 

I'm on a Mac mini M1 with Outlook 16.57 (22011101).

I dont know how big of a deal it is for you (or if maybe you already tried it) but I would delete the profile using Finder, delete the remains from the Trash and recreate the profile.

Deleted profile, deleted all sql lite files, emptied trash and rebooted. Still no search results.
Search worked on this machine up until mid December; couldn't tell you the date or the update that broke it.

Even after the 16.57 update I tried to remove every instance of MS Office and reinstall all of them.