Outlook Desktop M365 error: "This is not a valid file name." when sending email with no attachments

Copper Contributor

Latest version of Office Desktop - for some new email, when we reply, we get an error message popping up: This is not a valid file name.

There is no attachment on the email, we're just replying to the email.  It is random why this occurs. 

We have tried removing signatures, checking images in the email, it is random.  If we set the email format to plain text, we can reply but all formatting, links etc. are lost.  We can reply to the email in OWA with no problem so why is Outlook Desktop unhappy?

Have tried creating new Outlook profile on new machine, creating new .OST file, removing AV software, removing MalwareBytes, clearing the Outlook cache, deleting temp files, clearing Microsoft Edge cache.  

Have opened a case with Microsoft Support back in early November, but no help there.   

Thanks for any help!

11 Replies

@gt-seaI also get this and it has only started happening in the last month or less I think. Only happens in desktop version of Outlook

If I reply or forward some emails I get the same "This is not a valid file name" error message.


Fix is to look for and delete any images that are in the body of the email then it will send ok. I think it has to do with broken image links but not sure.

Thanks k-mccoy for the suggestion, we have found that if we have a long email thread we can chop away at the bottom of the thread and get it to go, but that is not really an acceptable workaround for most users. And for some emails, it is the 1st reply to the email so what could not be correct about an image? The email was just received 2 seconds ago and it looks fine.
If there is something wrong with an image in an email then Microsoft should highlight that image at a minimum so the user can delete it and move on OR is should just allow us to send the email. Nothing is a bigger waste of time than to write-up your reply, hit send and then get told "... not a valid file name" and you can't send the reply.
Frustrating here - this has been going on for over a month and Microsoft knows about it and can't tell us why this is happening.

@gt-sea Ah, someone else experiencing the same issue, I really struggled to find any info on this around the web before now.


I have done some digging myself, it seems also that if you click away from the email (quick reply/forward) so it remains a draft email in the list of emails for whatever folder you're in and then switch back, the entire email body vanishes and becomes totally blank.


It acts as if wherever it caches this while writing the reply is beyond the windows character limit, however, I have tried outlook in online mode with no caching enabled, I have cleared appdata, cleared temp files, checked while writing emails for anything generated in temporary internet files or other locations and not found anything.


Hope we can find a solution to this, but also somewhat glad to see it's not just me going crazy!

I have also been getting this error for about a month now. For some reason, it is only out of a specific inbox folder. The same user can forward or reply from the web app and from their phone but gives the error from the desktop app. (We have tried both office 2019 pro and M365). Reinstalling will work for about two weeks until the issue pops up again. @gt-sea 

Thanks @ITGDaryl. Sorry you are having similar problems but kinda glad others are reporting this issue - maybe Microsoft will put some resources behind trying to solve this.  I have an open support ticket with Microsoft about this issue and the ticket was opened on 11/9 and Microsoft really has done nothing to resolve the issue.  I'm on my 4th ambassador (the last one went on holiday and I found out 2 days later when ambassador #4 introduced himself).  

I would think they could have an Outlook Desktop SME look at this issue and see what is triggering the error in the desktop software.  Email message is fine in OWA and/or on Phone APPS - so what in the email does Outlook Desktop not like?  


I've been having this same issue for a couple of months now. Desktop Outlook 365. For me, it's when I try to forward an email.




Exactly this! we need Microsoft on this, we need a fix!
We've been getting the exact same error for random internal people. A customer of ours just told us they get the error when responding to some of our emails. It's not all emails and reply's seem to be worse.
Anyone know if the latest update on the 4th January addresses this at all? as the customer in question is running on an RDS I cannot easily update without getting everyone off the system first.

If anyone notices this has vanished at any point, please do update us.
Hi all,
I upgraded to M365 Version 2112 (Build 14729.20194) yesterday and I'm NOT seeing this problem on older problem emails I had flagged. I can reply to them and forward them with no errors in Desktop Outlook.
I read the release notes on the current channel - https://docs.microsoft.com/en-us/officeupdates/current-channel - and Microsoft mentions several fixes to Outlook where Outlook "...stopped responding when retrieving personas or an unexpected close when loading people photos". I had noticed that some of our trouble email, if looked at in OWA had recipient headshots in the header and in Outlook desktop they did not. Told that to Microsoft support 2 months ago.
Fingers crossed, this is fixed!
Can anyone else confirm that the issues are no longer presenting themselves following the update mentioned?