Outlook 2019 Security Alert for "Certificate"

New Contributor



When I start Outlook, it starts to check send/receive mail...but I typically get the this security alert. (File is attached)


I have tried "install certificate"  for the "current machine"...and let the certificate import wizard "automatically select" a certificate store.  

It says the "import was successful".


BUT...I still keep seeing the security alert again and again, when I start up Outlook.

(BTW....the email account is my MS Exchange account at work....which is secure.)


Otherwise it gets the mail and info for that account when I hit "proceed"...but why do I keep getting this security alert.  Is there a way of telling Outlook that this account is OK, and not to warn me over and over again?

5 Replies
I would check if this is somehow related with your network. Anyway, you can disable the warning but probably that's not the best idea. Have a look into: https://support.microsoft.com/en-us/help/3211279/outlook-2016-implementation-of-autodiscover

If you want to disable it here is the regkey:
Key: HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\AutoDiscover
Value: ShowCertErrors
Default: 0
Data: 1 = Show certificate warnings/errors; 0 = Don't show certificate warnings

@Ricardo Viana 


You're right, fiddling and disabling warnings in the registry are probably not the best idea.


I know this network (my large employer) is secure, I wish there was a better fix or workaround....

I meant to say something related to the network (DNS, proxies, firewall...), not that it isn't secure.

Take a look into this article, if you haven't done it yet: https://support.microsoft.com/pt-pt/help/2772058/the-name-on-the-security-certificate-is-invalid-or-...

Otherwise, I guess the best way to have it sorted out is opening a support ticket with MS



Is there any update on this? We have also got similar issue.


I tried to edit the register under the following key:
However on my system there is no "AutoDiscover" key.
How do I switch off the annoying error msg about a certificate? 
I tried to install one but the message keeps coming up...