Outlook 2019 Search - No Results - Tried Privacy and mdutil

New Contributor

After an Upgrade to the new Mac OS Big Sur 11.2.1,  Outlook (16.47 (21021804) was acting a bit odd. Searching only brought up old content, nothing new.

 

I added my Main profile to the Spotlight Privacy, rebooted, removed from Spotlight Privacy, rebooted. Nothing (yes I waited Days)

 

I did the full spotlight re-index via:

sudo mdutil -i off /
sudo rm -rf /.Spotlight-V100
sudo rm -rf /.Spotlight-V200
sudo mdutil -i on /
sudo mdutil -E /

Waited a few days, and nothing still shows up in Outlook search.  "No Results" is all I ever get. 

 

I was going to create a new Profile today, I just hate doing that with a 24GB Mailbox Profile.

 

Any other Suggestions?

1 Reply
Same here, I did all that, and absolutely nothing.

It doesn't matter what I look for: flagged items, items with certain categories, or plain old messages from a certain person. It worked perfectly after I first installed Office 365 a few months ago and then magically, this month (March 2021), it stopped working. Completely. None of the actions (re-indexing, removing profile, etc, etc) change that.

I am considering moving back to Mac Mail, because this is unacceptable for ultimately a mail / database tool. What I find most frustrating is that this search problem in one or another form seems to exist for over a decade.

Microsoft: solve this ridiculous bug! I've wasted well over three hours on it