Outlook 2016 error 0xCAA70004

Iron Contributor

Some users report this error message in Outlook 2016.  Unable to determine the root cause of the message.  Information on the error code is next to none.  Any thoughts...?



25 Replies

I have done a quick search about that error code and it seems that somebody has already had a similar issue. It seems that Outlook thinks that you are disconnected from the internet.

Here is the link to the original thread: "https://goo.gl/3Wr2F8"

I looked at the article you mentioned and it has nothing to do with this error code.

I am receiving the same error.  Any thoughts?

After extensively working with Microsoft Support engineer, we determined that it was an external DNS issue.  As the error is intermittent at times. When the pop-up was present, other Microsoft URLs would not resolve.  Prime example was https://login.microsoftonline.com, but https://outlook.office365.com would.  Other websites and Office 365 services are unaffected. We were not able to determine if the DNS issue was with the local Internet provider or a global provider.  It's not much to go on, but somewhere to start.

Running into same issue!

I was getting this same Pop-up, and I was able to fix it by running the office365 diagnostics tool:



The diagnosis was invalid cached credentials, and the tool automatically cleared credentials and restarted outlook. 

I recently updated office on my laptop - so credentials may have been cached since before that, resulting in the failure.  That's mostly guessing at a cause though.

The diagnostic tool worked for me, thanks! I have seen this issue with a number of our users (random and unexplained) however the external DNS does not appear to be our problem. Our helpdesk technician usually ends up reinstalling Office and that solves it. But when it happened to my own computer, the reinstall only lasted a few days then the popup returned. I downloaded the tool and it resolved it within minutes. I hope the fix stays this time! Thanks for the post Jett.



I have the same issue when trying to add an Office 365 account :



followed by this error message:




Unable to add the account. I tried the support tool but with no success.


Can you please describe ste steps you perform using the tool? There is a lot of options...




Thank you!

Which steps did you take in the tool? I could not resolve the problem with the tool yet.




Hi, i had the same problem and corrected it like this:

Access the following registry path


Add a new entry of type REG_DWORD with the name EnableADAL with value 0

Remove the DisableADALatopWAMOverride entry if it exists.

Automatically when opening the outlook it will open the popup requesting user and password.

I don't know where you got this from, but this fixed my issue! Thank you!
This worked for me! Thanks!
It worked for me too

@Alex Melching 


Go to HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity

Add a new entry of type REG_DWORD with the name EnableADAL with value 0


Remove the DisableADALatopWAMOverride entry if it exists.

@Alex MelchingThanks for linking that article; it gave me the clue I needed to solve this problem.


Configuring Windows 10 to access the Internet through a local proxy server (such as Privoxy) creates issues for Universal Windows Platform apps, which by default are forbidden from opening a network connection to the local machine. This includes the Azure Active Directory (AAD) broker plugin used by Office applications to perform authentication, which is effectively blocked from accessing the Internet when a local proxy is in use.


The solution in this scenario is to use a tool like Tiago Andrade e Silva's Loopback Exemption Manager to explicitly grant permission for this plugin to access the local machine, thereby allowing it to connect to the proxy server and, through it, the Internet. Once I added an exemption for the AAD-broker plugins on my computer I was able to sign into my Office account again and use Outlook without the "0xCAA70007" error code reappearing.



hi guys, "CMD" and "ipconfig /flushdns" that work fine for me ^^@simonsouth 

@Alex Melching 


hi guys, "CMD" and "ipconfig /flushdns" that work fine for me ^^@simonsouth 

@Timo Riemer hi guys, "CMD" and "ipconfig /flushdns" that work fine for me ^^