New 16" Macbook Pro running Monterey broken search on Outlook

New Contributor


Just migrated to a New 16" Macbook Pro running Monterey broken search on Outlook

OS is V12.2.1

Outlook on V16.61

Search gives no results

All I can see on the o365 help is running the latest version as of 16.57 fixed this, I'm on a latter version & still not working

Any help please?

3 Replies

Hi @Jono15 ,


Can you check two things?


1. Go to System Preferences > Spotlight and see if everything is checked. Also while in Spotlight, switch to Privacy tab and make sure you don't have any locations added.



2. To to System Preferences > Security & Privacy > Privacy tab > under Full disk access > check Outlook. 


Reboot mac and check.


Last thing, I would try to switch new/legacy interface. 


If you have Legacy (old) interface, you can switch to new, see below.



If you have new, to switch to Legacy click on Help > Revert to legacy outlook.





3. Check if your profile name contain any special characters. if yes, delete them (rename profile name). 


Go to Finder > Applications > find Outlook > right click on it Outlook app and select Show package contents.



Once there, go to Content > SharedSupport and click on Outlook Profile Manager. If you see weird names click Edit and rename to something simple.


4. The last option is to re-index the Search.


For that, open the Terminal app on your Mac and enter the following command. 

mdimport -L

In the list of indexes that appear, check whether there’s an entry that resembles “Microsoft Outlook Spotlight Importer.mdimporter”. If there are more than one entry with the same name, you will need to reindex your Outlook database. 

For that, enter the following command inside the Terminal window and press Enter


mdimport -g “/Applications/Microsoft Outlook Spotlight Importer.mdimporter” -d1 “/Users/<user_name>/Library/Group Containers/UBF8T346G9.Office/Outlook/Outlook 15 Profiles/<my_profile_name>”


In the command above, you will have to replace

  • <user_name> with your Mac’s username
  • <my_profile_name> with the name of your Outlook Profile


Hope something helps from this. 





Thanks for the info

Carried out points 1 through 4

Spotlight fine

Security & Privacy under Full Disk Access outlook is not there

I then went t5o new outlook which I loath & the search function works, went back to legacy, it does not work???

On the Profiles bit I just see

Jon New at 240816 which was last modified on 24/08/2016 12:22

& Main Profile Last Modified Today 21:27

In Terminal there is only one outlook entry


So any thoughts as to why indexing works in the new version of Outlook but not the legacy?

Many thanks

Hi @Jono15 ,


It is really difficult to pinpoint the cause. In Outlook, even on Windows and especially on Mac, searching was always a very tricky issue. Recently, users reported some problems with the search function, and Microsoft responded with a fix. But even with the fix, I see people struggle to make it work. That is probably why Microsoft is switching to new interface. Here is the link:

Search in Outlook for Mac returns no results after installing macOS Monterey 12.1 (


The legacy problem may be solved by simply removing Outlook and reinstalling it. 


What I can tell you is that you should stick with the new interface for the time being, unless you are missing some features. In my opinion, I like it better than the old interface. 


Good luck!