High CPU Use on all Office Tools


This week and maybe last week, my machine (I7 laptop) has been running the fans excessively.  I took a look yesterday and found:



Not actively doing anything, just files open.  Anyone else notice this/have an explanation/solution?

14 Replies

@_Scot_ Hello Scot, hard to say really. Could be just about anything! Are you using M365 Apps for enterprise (formerly O365 ProPlus)? I am just guessing here but it could perhaps be related to the 'Connected Experiences' and/or 'Optional Connected Experiences'. Not that it's something I heard of, I am just thinking out loud here.


If it happens again go to the Account Privacy settings and uncheck these to see if it makes any difference. From an Office App: File - Account - Manage Settings. That is if your admin is allowing it or not of course.





@ChristianBergstrom , Thanks for the tip, I tried disabling "Optional connected experiences" but doesn't seem to change anything.


CPU (and hence power) use are high 100% of the time by all the office tools.  In the Office Account pick, it says "Product Information, Subscription Produce Microsoft 365 for enterprise"


Any of the tools use ~15% of the CPU continuously.  This just seems ridiculous, are there any diagnostics I can run to tell me what they are doing?  Disk/Newtork/GPU are all low but CPU is not.  If I run Word, Excel, PowerPoint and Outlook simultaneously, I get:



All doing nothing, just selected create new in all but Outlook which is just sitting at the in box.  Iconifying makes no difference.  This is maddening.  Disconnecting from the net does nothing either, what could they possibly be doing to use that much CPU?

@ChristianBergstrom, thanks again.  Tried the repair, tried removing and re-installing and unfortunately:




@_Scot_  I did find a work around.  If I disconnect from the net, start the tool then re-connect, it never goes into the high CPU use mode.  Bizarre but I can live with it.

Thanks for the update. Sounds odd. Wonder if it’s related to the telemetry settings, do you know if it’s enabled for you? https://docs.microsoft.com/en-us/deployoffice/compat/manage-the-privacy-of-data-monitored-by-telemet...

As you asked about a support tool previously. Maybe not applicable now as you reinstalled, but good to know!

I have the same exact problem and the same workaround worked for me too. Hope they fix it in the next update. Also, if it helps, we don't have telemetry enabled.

@kracas @_Scot_ which builds are you using?


Build 12827.20210 Click-to-Run


Version 2005. Apparently I'm on preview channel, should probably change that then :smile:

@kracas Haha yep, probably. It's nice to receive updates as soon as possible but sometimes it isn't ;)


Wonder if @_Scot_ is using the same version.

@kracas This is exactly the same version and build I'm running.

Then we know. Thx for the update!