Frustrating password prompt issue

Copper Contributor


Hoping someone here has had the same issue and managed to fix it as I'm lost now!

We have an issue where Outlook will every so often (generally every day) prompt for a password but have the password field in the background. Now I've come across a very similar issue previously where we could just 'disconnect' the work account within settings and all would be good.

This is not possible due to the current setup which I will outline below. Chances are something I've done in here is the root cause...

The setup is utilising Azure (Windows) Virtual Desktop.

We have an Active Directory server which syncs to Azure AD for the users

There is then 2 session hosts (with 1 spare which comes on when needed).

These session hosts are hybrid AD joined, which is where I think the issue may lie, but cannot say for certain.


Interestingly, it only seems to be an issue for users that have more than 1 email account on Outlook, all on 365 and all on the same tenant.

I've tried the following (I do also have a ticket with MS, but in typical fashion, they're not overly helpful at first...):

Clear saved credentials and add the following registry keys:

EnableADAL (set to 0) and DisableADALatopWAMOverride (set to 1). Both under 'HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity'

This did not resolve the issue and if anything made it worse...

I've also tried what's detailed in this link but it didn't seem to help either.

I'm kind of stuck with what to try next aside from doing an Office repair, but I don't know how much this will help as it happens across VMs.

It should be noted the current way to temporarily fix this is to close Outlook, go into word, go to Account and click sign out multiple times and then load up Outlook again and the password prompt will appear.

Has anyone come across anything similar, if so, were you able to fix it and if so... how?

4 Replies


In Edge, you can automatically switch between user profiles - between a private and work profile - there is a button to allow single sign-on.
I do not know if it will work, but sometimes such simple solutions work.

@liamk1105 I have the same problem with a handful of end user devices. The issue only occurs on the device. It doesn't matter who is logged on. Re-installing office didn't help. Did you get a solution?

@Jimm85 unfortunately not, it's driving me round the bend! I have 3 tickets open with Microsoft (as they are for different clients). Once I have a solution I will post here

@Jimm85 Hi, just to let you know I have fixed this by doing the following:


Open regedit as the user and navigate to HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Common\Identity

Create a new DWORD with the name "DisableAADWAM" (without speech marks) and set the value to 1.

Create a new DWORD with the name "DisableADALatopWAMOVerride" (without speech marks) and set the value to 1.

Sign out and reboot the machine


You can probably add the keys via a GPO