Challenges running first Outlook Web Add-in

New Contributor

I am trying to get my first Outlook Web add-in to work. So I:
1. Followed the instructions at "Tutorial: Build a message compose Outlook add-in"
2. Per those instructions, I used the Yeoman generator to create an Office Add-in Task Pane project for Outlook. I followed the instructions to the "Test the generated add-in". So only the manifest had been changed. A very simple add-in at this point.
3. Tried npm start from the command line.

4. At this point, I can view the welcome page in a browser at the URL https://localhost:3000/taskpane.html.
5. Outlook is started with as a result of npm start. There is no "Show Taskpane" button to be found anywhere in Outlook.
6. Navigated to to follow instructions for "Sideload manually". This PC has Outlook 2016, so went to that section.
7. It says to select the "Get Add-ins" button, but this button is greyed out.
8. Checked File > Options > Trust Center > Trust Center Settings > Privacy Options > Privacy Settings and looked for “Enable optional connected experiences” as noted in and several other pages. “Enable optional connected experiences” does not exist in my Outlook installation. "Turn on all connected experiences" does exist and is enabled.
9. Looked at other alternatives for sideloading problems. Found says "It turns that under settings you may need to turn on which "actions" are available in your read/compose pane." I am not finding exactly to which "settings" this refers.
10. Tried the same on a different PC with Office 365. The results were essentially the same: No "Show Taskpane" button and the "Get Add-ins" button is greyed out. In this case, “Enable optional connected experiences” exists and is checked.


I also tried an Excel Add-in and it worked as expected.


What am I missing here?
Thanks in advance...

1 Reply
After a lot of looking, I ran across the answer to my own question: on , I have found a statement that says: "The client must be connected to an Exchange server or Microsoft 365 using a direct connection. When configuring the client, the user must choose an Exchange, Office, or account type. If the client is configured to connect with POP3 or IMAP, add-ins will not load." I had only POP3/IMAP accounts, and when I added an account, it magically began working. I hope this helps someone else!