Advanced search not showing up

Copper Contributor


I am on Outlook for Mac version 16.64 and I can't access Advanced Search. I tried accessing it through Edit > Find > Advanced Search and as well as through using the shortcut. 


This is my goto function for finding email. What can I do to bring this functionality back?




macOS 10.15.7

8 Replies

@mrcdssldrpI have the same issue. Pressing Shift+Command+F or selecting "Edit => Find => Outlook Items Search..." and then selecting "Advanced" from the ribbon still works. That said, given I have a very poor memory I use Advanced Search a lot so it's very annoying that the keyboard shortcut stopped working...

A colleague informed me that while indeed broken in legacy Outlook it is still working as expected using New Outlook. Unfortunately I cannot switch to New Outlook yet. Still no automation available; neither AppleScript nor VBA. AppleScript was promised for this year but pushed back to 2023.
Thanks for your reply. Good to see your confirmation on the same issue. Thanks for the workaround, that works for me as well

I can't move to new outlook yet as I am using POP accounts, and there are still a few drawbacks with POP email in New Outlook

I contacted support and got the following reply:

We have noticed this issue experienced by few of our users and this has been reported to our Development Team. I understand the severity of the issue and the requirement for the resolution. Since this needs to be tested and the fix needs to be rolled out, we would not be able to provide an ETA on the fix.

Fix for any BUG filed with Outlook will be rolled out through "Updates". So we suggest you to keep your Outlook up to date. You may also refer to the Microsoft blog, where all the updates to the latest features and fixes are announced -

As a workaround, you can manually open the advanced search in Outlook for Mac, by clicking on Search bar on the top right corner then, in the search ribbon click on Advanced. See if it works.
With the latest Outlook for macOS update the "Option+Command+F" keyboard shortcut for "Advanced Search" is working again as before.
Yes. Glad that the first next update delivered the fix.
How do I use this? I have latest Beta version 16.66 (22092502) and when I am on the Contacts pane and press Option-Command-F I just get the error 'beep'. Please can you advise? Thanks