Something Went Wrong - OneDrive Sharing file and folder

Brass Contributor

Getting error while sharing file and folder from OneDrive. any workaround for this issue 

26 Replies




@Suraj_Sukumaran  Any update on that? I'm having a similar issue when trying to share a file or folder.

No work around yet :sad:


best response confirmed by Suraj_Sukumaran (Brass Contributor)

Hi @Suraj_Sukumaran,


Based on the screenshots you provided, this looks to be an issue that occurs when you have too many items with unique permissions in the same site. You can read more about the limits here.


Generally we recommend either moving content into separate site collections to reduce the number of unique permissions or look for other ways to group files together (say, in a single folder that is shared) instead of sharing the files individually. 


Hope that helps!

Stephen Rice

Senior Program Manager, OneDrive

@Stephen Rice 

I tried OneDrive (for Business) today for the first time and I'm also getting "Something went wrong". Technical Details: {"status":-1,"code":"NoConnection"}


I doubt it is a problem with too many items with unique permissions in my case - I have a grand total of 2 folders (the built-in Notebooks folder and the test folder I just created), and one item in the main OneDrive folder and one test item in the test folder.


When I right-click on the test folder and choose the OneDrive share option, after about 2 seconds I get the "Something went wrong" dialog.


Could it be a GPO setting?



Found a solution (and maybe we need a GPO to control it).


Go to "internet properties", "Advanced", "Security" and uncheck "Do not save encrypted pages to disk" and click "Apply". 


After this change we are able to share a OneDrive file in Windows Explorer. 


I am having a related problem.  I've been able to share OneDrive files for 1-2 years (at least). Today, OneDrive refuses to share any file. I am using an iMac so the Internet Properties solution won't work. I've attached a screen shot of the error pop-up I am getting.


Any help appreciated.

Hi @NBIrkett,


That definitely looks concerning! Does this happen on every share or was it a one time thing?

Stephen Rice

Senior Program Manager, OneDrive

Is it the same from all clients? (desktop client / Online / mobile app)

Anyone else in your organization that have this issue as well?


@Stephen Rice 

I get the same error for every file I try to share, including files that I shared in the past.



Thanks for confirming. Please do open a support ticket for this as well!

Stephen Rice

@adam deltinger 

I've tried sharing from the OneDrive file in the MacOS file system and from the online OneDrive Web page. I don't know if anyone else is having trouble.


I have a personal Microsoft 365 subscription which is what I was trying to share from (that account is what shows up when I check the account information on the web page). My university has a corporate subscription but I couldn't use that to log-in to (claimed the account didn't exist.


Just tried again to share and got a different error - unable to reach the server

@FDC2005this solution worked for me but when i restart the laptop internet options settings "Do not Save Encrypted Pages to Disk" tick mark comes back.


Only few users facing this issue so changing this option from GPO is not good solution.

Any other fix you came across. I still understand root cause for this problem as well.





An update.  I exchanged several emails with a Microsoft tech support person over two days. Then, the sharing started working again.  I didn't change anything.  And, I have received no explanation from Microsoft about what the problem was nor what was done to fix it. Based on it being fixed without changing things at my end, I am assuming that there was an issue with a Microsoft server. But, I can't say for certain.


@FDC2005this solution worked for me but when i restart the laptop internet options settings "Do not Save Encrypted Pages to Disk" tick mark comes back.


My guess would be this setting is controlled in some way by your organization IT. If you are able to uncheck the box then it may not be a GPO. Instead, it may be a script or settings that run when you login with a domain account. Either way... probably needs to be handled by organization-wide IT.


We haven't found any other solution...



Thank you very much, your solution worked. 

To apply it via GPO go to:

User Configuration\Policies\Administrative Templates\Windows Components\ Internet Explorer\Internet Control Panel\Advanced Page\Do not save encrypted pages to disk.



This helped in my situation (and 3 more people in the company)

Thanks a lot!


I guess the problem is that our accounts are domain accounts and not local accounts and that there is some setting forbidding us to share...


Amazing, works !
this solution fix the issue for me, thanks