SharePoint Online Team Sites - AutoMount

Brass Contributor

Hi All


The OneDrive for Business sync client GPO Team Site AutoMount feature still not available. Any ETA on GA?



Chandrasekaran C N

71 Replies

@Christian Taveras Thanks Christian! That would be very helpful if you end up finding the setting.  I have a ticket open with the Intune team, but sounds like I should probably change it to the SPO team. 


Glad to know I'm not the only one experiencing that!

To anyone else not able to see "Copy Library ID", I found the issue on my tenant. 


I had to change this setting to "Start the new client" within the settings tab on the SharePoint Classic Admin page. 




I am unrolloing this feature in my organisation and it is syncing fine, but I encountered a new problem. I have everything configged in InTune: 2 libraries sync fine with the "device" key for every device, then I have a policy for every departement to sync its own library. Now InTune is giving me conflicts for those user who is a member of 2 departements. Why doesn't it just sync both libraries, I don't see a conflict? It used to work through GPO when we had a hybrid setup.


Any ideas?

Hi @mronsmans,


I am still going ahead with fileshares to sharepoint migration but, I am unrolling Team Sites - AutoMount as  we have constantly issues with never ending synchronisation going on and on and on. I have only rolled this out to small group of users (thanks God). So the plan for now is to deploy via GPO shortcuts to the desktop with direct hyperlinks to the teamsite they require. That way I will still utilise cloud but wont wait for M$ to release feature that actually does work. Such a shame.



Out of curiosity, what format are you using for the links on desktop? If I use odopen://sync/? and then the same link formatting as the GPO, I get an error that One Drive can't open it



@bkladdMy GPO value starts with "tenantId="  then LIB id after nothing else before that and ITs working for me in my test environment.

@Christian Taveras 


**Edit for clarification**  I've had a lot of frustration with this process, so I was trying what @pgawronski posted about last week. That is using a script rather than GPO to accomplish automounting for the user


I did some more trial and error, and if I run this PS1 as the user, it works. Haven't tried running via our RMM which runs as system yet.


$LoggedOnUser = "$"
Start-Process "odopen://sync/?siteId=%7B0718xxxxxxxxxxx69%7D&webId=%7B6549dxxxxxxxxxxxx58962d%7D&webId=%7B65xxxxxxxxxxxxxxxxxxxxxxxxxxx2d%7D&listId=%7BF2716A0A%2DE5C0xxxxxxxxxxxxxxxxxxxxxxxxxxxxx07%7D%7D&userEmail=$LoggedOnUser&webUrl=https%3A%2F%2Fxxxxxxxxxxxxxxxxxx%2Esharepoint%2Ecom%2Fsites%2Fxxxx&onPrem=0&libraryType=4"

@bkladd  Major difference here I am not using POSH Cmds, I am only using GPO.

Yeah, I just edited my post to clarify I was working on a Powershell method.

However, I did just notice after several hours my machine finally started working via GPO. The key was editing the webURL as @Deleted put in his post. Although the tenantID was correct for me, I didn't have to fix it as he mentioned, so perhaps they are making progress...
I tried to use the Intune method as Id love to move away from GPO and DC's in general but those intune settings just do not work for me. Azure support said its still basically in preview....

FWIW you can get the library ID by opening the library in Internet Explorer, clicking sync and then cancelling the operation. The Library ID button will appear.

I totally forgot to update this. The support team got there in the end, and this should now be fixed for everyone. There was an issue that caused the Library ID to pick up a different Tenant ID value - especially for relocated tenants (Data Residency moves, EDU, GOV, etc) - and that caused the policy to not work. We updated the Library ID value with the correct values and it all started working. This change was rolled out as a fix shortly after my case, so should have been resolved... umm... years ago (oops).