Read Only (Padlock Icon) files - OFDB 17.3.6743.1212

Brass Contributor

I am currently using the ODFB preview client 17.3.6743.1212 to sync a single group and a single SharePoint online document library.  The Office 365 group library is working as expected but all the documents stored in the SharePoint library have a green padlock.  When I open any of the documents, I am informed that this is an offline copy and the document is read only.

Has anybody else experienced the same behaviour?  I assume if I deleted and re-synced it might solve the problem, but that’s not a viable solution after the sync tool has been deployed to many users.


49 Replies

@Olivier Jegaden wrote:

Synchronization appears to work if you place your required columns within a Content Type and apply said Content Type to the library. If you add a column to a library and make it required, it locks files again in the local synced folder (Windows 10, new ODFB client)

This is not true in my case - I use content types exclusively, some of the columns in the content type were mandatory, so them being in a content type did NOT allow the data to be editable

I have the same problem. This is terrible and frustrating!

Just discovered this thread because I'm having the same issue. Didn't know this was a bug. Hopefully it will be fixed soon. 

This is the same problem we have. What is the solution? How can we set it not to get the padlock?


The only way is to disable versioning, as far as I know.

I am having the same issue.

This is the first library I've tried applying multiple custom columns to. Not sure if that is the problem. 

I was doing it on a siteassets library, I didn't add any custom columns. I think just the fact that versioning is on does it.

It turns out that the "Required Metadata" in a column was the problem. I made the column not required and it is now syncing without the padlock (write access is allowed).

Hi, I finally found the solution to my nasty green padlocked files and folders. Looks as though this is is a "feature" rather than a bug:


In Sharepoint (365) went to Library Settings for the Library,

Versioning Settings,

under "Who should see draft items in this document library?" chose "Any user who can read items" instead of the default (?) "Only users who can edit items"

The padlocked icons disappearered after exiting the sync client and logging back in to ODFB



To be precise, though, the default is "Any user who can read items", i.e. the first radio button. It changes to "Only users who can approve items (and the author of the item)", i.e. the third radio button, when you enable "Require content approval for submitted items".


I also found one check, what can be only this setting :
"Do you want to approve content for submitted items?" - No

If is Yes - also I have Pdalock Icon

Why should we have to give one benefit for another. I need the metadat required columns, I have any user who can read items checked and none of this has worked. However, yesterday when I booted up my system for the first time I went right to my files locally and they were all available and I had changed nothing. I thought Microsoft had corrected the issue but later in the day they were back so what was that abot?

I have the same problem and even if I changed the settings to what other tell is working, I still have the Padlock. I have wondered some time, why I couldn't update my files locally, it has been working for some month ago - and I have not made any changes on the Document Library. Obveious Microsoft changes :(
I hope that Microsoft pretty soon get this working again, whithout so many limitations. It is such a nice feature and we might need to change our plans and what we were planning to learn our users.

I have revert a single PC back to the old One Drive for Business (groove.exe) with the instructions below and everything is back to working the way it was.


To enable groove.exe to sync your OneDrive for Business library, follow these steps.

Disable onedrive.exe from syncing a OneDrive for Business site

  1. Find the correct OneDrive for Business cloud in the notification area on your taskbar. When you move your pointer over the correct OneDrive for Business cloud icon, you should see OneDrive - <organization name>. Any other combination of text, like OneDrive for Business – Up to date or OneDrive – Personalis not the correct icon.
  2. Right-click the OneDrive - <organization name>cloud, and then click Settings.
  3. Select the Accounttab, and then click Unlink OneDrive.
  4. Close the sign-in dialog box.

Modify the registry to allow for groove.exe to sync a OneDrive for Business site

Important Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

  1. Locate the following registry key: HKEY_CURRENT_USER\Software\Microsoft\Common\Groove
  2. Double-click the DisableMySiteSync key.
  3. Change the Value data field to zero (0), and then click OK.
  • Double-click the SPOTeamSiteRestrictions
  • Change the Value data field to zero (0), and then click OK.


Finish setting up sync for OneDrive for Business

  1. Restart your computer.
  2. Right click on One Drive cloud and hit Sync new Library – cut and paste url

Tested again with the latest build. No changes. With mandatory metadata, the sync is read-only.


Fall Creators update is expected to ship very soon. I really hope this is fixed. I have clients waiting for this feature but this is useless with this type of restrictions.  


I also need this fix! Can't sync files that need checkout!

I had the same problem with "padlocks" showing in the ODfB folder, with none of the fixes proposed here or on other forums resolving it. No columns were mandatory, check-out was off etc.

After some testing I found that one of my custom columns had become "secretly mandatory".

I had added a Site Content Type containing a Required column to the library, but later on had changed it to Optional. It appears that the column was still defined as Required in the library itself!

I simply deleted the column from all content types in the library, and then also from the library itself - and that fixed the problem! The locks disappeared in OneDrive almost instantly.

Naturally, a better approach would have been to repair the column by changing it's properties with PowerShell. 

Don't know why anyone wants to use Sync.  Every time MS makes a change (frequently) they break something.  Microsoft have NEVER made a decent sync tool.  I am old enough to remember the truly horrible 'Briefcase' in Windows 98, and they still haven't improved since then.

I got the "read only" message on a library that was set to show minor versions only to those with edit privileges.  Changing that one setting fixed the issue immediately.


Whilst a solution is conceivable, I can see why that setting would make local file sync very difficult and complicated (in the same way as syncing a library that requires check-out for editing).  Surely in either of these cases it's sort of logical that local file sync would be read-only?

Is there a solution for this issue available  ?


I have the same problem at a customer :(


kind regards,


Vic Vergauwe