Read Only (Padlock Icon) files - OFDB 17.3.6743.1212

Brass Contributor

I am currently using the ODFB preview client 17.3.6743.1212 to sync a single group and a single SharePoint online document library.  The Office 365 group library is working as expected but all the documents stored in the SharePoint library have a green padlock.  When I open any of the documents, I am informed that this is an offline copy and the document is read only.

Has anybody else experienced the same behaviour?  I assume if I deleted and re-synced it might solve the problem, but that’s not a viable solution after the sync tool has been deployed to many users.


49 Replies
Hi I have the same issue did you resolve it?

The reason could be the following:

"When syncing libraries that require check out, or libraries with required columns or metadata, the files are synced as read-only. If you do make changes to these files, the changes will not be synced back to Office 365." from

That was the problem, thank you!

Thank you Salvatore, my files do fall into this category, do you know if Microsoft have any plans to fix the 'know issues'?  We have many document libraries where we have required metadata, so this will impact our users if its not fixed before the client hits GA. 

I have not heard of a specific committment by MS to solve this problem. But shortly (before the end of the month) the new OneDrive client should reach GA and we will see...

Yes, using the new gen client I am having the same problem when syncing a SharePoint folder.  I have raised the incident with Microsoft Engineers (who had a remote session on my system)  and they have escalated it to the Beta group who will release an updated client version - I hope soon!! If you right click on the blue OneDrive icon you can also report the problem.

Thanks, Geoff

If you are syncing libraries that require check out, or libraries with required columns or metadata, this at the moment is the expected behaviour, as already said. Otherwise it is a bug.

Hi, no I'm not doing doing either of these, and the MS Engineer checked if these had been activated somehow, but is not the case. It also is not related to SharePoint or local security permissions. I had been running the new client successfully, until updating to the Preview client (1212) a few days back.  I think it's a bug.


This was a known issue in the preview client and was listed, although not right at the top as it should have been!  The preview clinet has now been released as a full release, and this has STILL not been fixed.  I agree this is a significant issue that potentially hurts collaboration.  Everyone who is having this issue and is concerned should vote for this to be fixed on UserVoice

This is enormously frustrating. What on earth is the point of having a sync client that only works with the simplest of libraries? If they aren't going to fix this issue then at least don't allow libraries with mandatory metadata to be synched so at least people are aware.

I think this issue must somehow be related to a bug in Onedrive. I have document libraries which were syncing fine and I was able to edit synched files with the previous ODFB (groove.exe). After installing the new ODFB Preview (onedrive.exe) I noticed the better part of my libraries were synced as Read Only.


If I remove versioning altogether for the document libraries it works... but I need versioning so that is not an option.


However, having fiddled around with the settings for my document libraries for a while I noticed that I can use Versioning and make them sync as editable content. What I did first of all was disabling "Require content approval for submitted items?" and "Require documents to be checked out before they can be edited?".


The only setting I've enabled in Versioning Settings is "Create major and minor (draft) versions". By setting the Draft Item Security to "Anyone user who can read items" the library syncs fine and I'm able to edit content synched to my local PC via ODFB.


BUT, every time I change the Draft Item Security setting to anything except "Anyone user who can read items" (e.g. "Only users who can edit items") all content is synched as Read Only again!


Has anyone else experienced this?


I'm not using any Meta Data settings or mandatory columns. The document libraries I've tested this approach on are basic, straight out of the box Sharepoint document libraries on Sharepoint Online. I'm using Office 2016 too btw.

I also have this issue on a a basic document library with no check-out required, or mandatory metadata columns. The library only uses major versioning.

I got the same issue, basiv library, no check-out or mandatory metadata.





I have the same issue... Is there a solution?

Not as far as I can tell, we're still experiencing the problem and it's causing me a giant headache with one whole team reverting to workarounds and methods we planned on making redundant by now.  It's terrible for uptake of a rollout we spent a year planning.

It seems to me that I encounter the same problem. It is a bit weird that I have this problem only with one SharePoint site and all the other SharePoints work fine. However I can do everything I need online. It is a bit painful and makes it harder to synchronize and collaborate, so that I hope Microsoft is about to fix this bug.
Is there any information about a bugfix and a date when it might be released? 

I've also encountered this problem, but with a few other twists. (For the MS folks, yes, I tried all the ODFB steps in the "Fix OneDrive sync problems" page.)  Here's a description of our situation; perhaps something here can help lead to at least a workaround. 


Two individuals have a specific SharePoint document library ("support materials") synced which shows up as read-only (with the "lock" icon). They're unable to add any files to any of the folders in their local sync'ed copy. They have full access on SP directly (browser) as they are both listed as Site Owners. 


However, on my system, I have the same library sync'ed and it's fine - no locks. I'm able to modify/add/delete files and folders just fine. (Note: I set up Sync on my machine before one and after the other individuals mentioned above.) 


The SharePoint library does not have any required fields, does not require checkout, is set to use versioning (Create major/minor versions.) Basically the default settings. I'm not going to turn off versioning (as we need the version history already in place.) 


The mystery for me is why my sync'ed copy is fine while the two other folks have the "lock" problem with their sync'ed copies. If I could figure out what differences to look between my and their systems (Win 10), that could potentially help. Any suggestions as to what differences to look for? 


BTW, we're all running the same version of OneDrive and O365 applications. (All recently updated.) So that's not it. 

Same behaviour here. Why don't they just admit that ODFB does not work in conjunction with SharePoint? It never has in my experience. Why are they rolling this out when they know about such a bug?

Synchronization appears to work if you place your required columns within a Content Type and apply said Content Type to the library. If you add a column to a library and make it required, it locks files again in the local synced folder (Windows 10, new ODFB client)