Read-only for ios "files"

Copper Contributor

Hi, for my business account, it always shows "read-only" like the below snap. But for other locations, iphone or ipad, it works fine.

Please, any help?~ masters~


23 Replies

@bobbychen Hi, I have meet the same problem yesterday.  Have you find a way to solve?  If yes, please kind help me.  

@bobbychen exactly same problem, I just changed mi iPad and on the new device I have this problem, never had before

@bobbychen This seems to have been introduced by a recent update to the OneDrive iOS app. Exported file permissions used to be 606, and now they are 555. I am an app developer, and I use the Files app extension (DocumentBrowserViewController). I am able to programmatically alter the file permissions, but I do hope someone from Microsoft development is going through these forums, because not only the 555 permission make the file read-only - it also grants execution rights of programs to all users, which is a serious security issue.

thanks for the detailed explanation, but is there a simple way to have back all permisison on my onedrive files, i'm not a developer


The description of the latest update in the app store mentions that the files were made read-only only temporarily, while they were working on something. I believe this is unbelievably irresponsible, especially since Microsoft is hardly a small-time developer, and also considering they switched the permissions to 555 instead of a safe read-only of 400. The only thing a non-developer can do is to contact the app's support by shaking the phone when the app is running, and hope the next update comes out soon.



Yeah, noticed the warning in the OneDrive app as well. But here on my iOS devices (iPhone and iPad) I have write permissions on the OneDrive app, but the problem is on the Apple Files app, with the OneDrive “location”... Is that the same issue you have there, I mean, in the iOS Files App when trading to work with files stored on MS OneDrive?




That was exactly the problem. Files imported from OneDrive through the Files app or its extension used to have 606 permissions. Now it is 555. In my app I now copy the files to my app's documents and change the permissions back on the copy.



Interesting part is the “same thing” is working absolutely perfect on a Samsung Android Device, I mean, the Files app on my another device, linked to the same MS OneDrive account is working just fine. Let’s just wait for the MS to update the iOS OneDrive app and/or it’s permissions.


Thanks for your reply.

This is ridiculous behavior from Microsoft, but thank you for bringing this update to my attention - it downloaded completely unnoticed.
I am have the same issues as well and hope this gets fix soon I use this everyday. I thought I was going insane for a few hours till I seen this post.
Any new on the fix for this issue I have 2 ipads, one is runnung IOS14.0.1 the other is 14.4. The Ipad with 14.4 is now read only. I cannot edit any PDF, I need this for work come om MS we need a fix pleeeeease
I agree. Can we get an update on this Microsoft?

@Allen Taylor would love to see a fix to this i save from the web and cannot save to onedrive from safari.  i am a little confused with the last post that says one ios version worked and the other does not? is the issue with microsoft allowing ios to assess the files app or ios allowing ios apps access to onedrive ... well whatever it is, looks like a legit problem that needs a fix 

I have 2 ipads 1 has IOS14.0.1 the other has 14.4. The 14.4 ipad does not allow me to save or edit docs in onedrive. Fix should be easy?
This can be solved using below method:
- Save any document to your ios device For example "On My iPhone"
- Then go to that document where you saved it.
- Click on share that document
- Select OneDrive and then save to any particular location to your OneDrive
- Click "Upload Here"

Document will be saved to your OneDrive Location without any issues. Hope this will resolve the issue.
Nope, that's not FIX, that's a workaround which is a pain in the rear to do regularly, as well as being a security hole (transferring work documents to a personal storage area). Thanks for at least pointing it out as a possibility but Microsoft needs to (work with Apple to) fix this ASAP.
This is a major issue for our iOS users in continuing to adopt M365 and OneDrive as a cloud storage solution. Dropbox for iOS has continued to work just fine 🤨
I agree. This continues to reduce adoption of OneDrive and M365 for our users since this works in the iOS Files for other competitive products like Dropbox. 🤨
thank you for the workaround, we really just want to use the drive directly. I have too many files and when you start duplicating in multiple places sometimes you update the wrong one by mistake the recent lists are all messed up and the list goes on and on. Just this weekend I had my finance workbook go un-updatable when using ipad and the mac , i had to save a copy of it. something funny is going on and it should work like any other cloud drive. I wish we didn’t have to pay for it when it didnt operate like it should , wouldn’t that be something.