OneDrive Search File Contents

Brass Contributor

OneDrive is no longer searching file contents. I used to get search results from file contents before but all of a sudden it's showing results only if it matches the filename. What could be the issue? Pls help


Update: Microsoft has finally fixed this issue. I'm getting my search results as expected. Others, pls share your experience.

47 Replies

@csnarain How are you running the search? Via the web client? On a mobile device? Or are you relying on desktop sync (Windows or Mac)?


Have you tried any of the standard trouble shooting steps?

@Mike WilliamsI'm using the web client

Any help on this? I'm still not able to search any file contents. Only filenames. No clue on what's going on.


Can you tell us a little more about your set-up.  I'm guessing that you're using OneDrive for Business with the Modern interface?

@Steven AndrewsI'm accessing the regular web client for OneDrive from a web browser while searching for content.

Some problem here... everything was working fine a couple of months ago... now can’t search nothing except filenames.


@Jean-Sebastien DecarieI'm glad that there is at least one more person experiencing this issue as mine. Though Microsoft acknowledged this as a bug, there has been no ETA yet on the fix.

I asked MS about it and they know about it It's extremely frustrating that they can break something that worked, and take 2 months and counting to have no idea how long they need to restore it.

@hn_GBThanks for notifying me on this issue. Yes, it's indeed frustrating. Also as Microsoft points out, searching from one's computer (desktop/laptop) is not a workaround. I have TB's of data in my OneDrive and I don't maintain any indexes in my computer. I always rely on Onedrive's Mobile/Web interfaces and it's indexing service for my search queries.

Is there any progress in this error? I'm having the same problem on onedrive web and one drive app on ios.


Is there realy so many months no good search on Onedrive??

@WenDanMicrosoft doesn't seem to show any interest in fixing this bug. They don't even have an ETA for the same. Do they really understand that we're paying for this service?

It's been like this for months. None of my content searches are working on mobile/web interface.

@Steven Andrews 


I'm experiencing this same problem from both my personal data via using Chrome and from by Android phone's OneDrive app.  Search ONLY finds files with that have the search text in their names. I hunted for something in the Android and online OneDrive configuration settings and came up empty. I have a LOT of files and no good way to find what I'm looking for. 

Is Microsoft listening? More and more customers have started reporting this and the experience is becoming annoying day by day.

I don't believe Microsoft is listening. This bug eeds to be urgently fixed!

@antenor69- I totally agree with you. I'm literally fed up with Microsoft on this. They've been sitting on this bug for months. I badly want to escalate it but not sure how and where to.

Unfortunately, same problem - thinking to move some core data to other providers @Ihanescreennamesmore 

@csnarain I am facing the same issue.  Someone said to use Content in the front of the word.  However, that gave me results of filenames and none of them had the word Content or the word I was searching for.  MS needs to make this easier for users


There is also this option.



@csnarain Same here. It used to be good, but now it is literally non existent here.

I'm having the same problem. I cannot search inside PDFs files. I'm using OneDrive Web. Google Drive is able to do so. This is a real pain point, as I was considering subscribing to Office 365 but I'll wait until this problem is resolved. I have a lot of files, content search is essential.