OneDrive for Business falsly throws invalid filename error when saving word docs

Brass Contributor

One of our users is getting the error below when attempting to save over 50% of her documents in OneDrive for Business.

the errorthe error

What is odd is that the filenames don't have % in them but the error seems to show that they do.  If she changes the filename by removing about 25% of it, then it will save.


Here is what I've tried:

  • the file path is not over 200 characters so the 259 limit isn't the reason
  • it doesn't contain any invalid characters  " * : < > ? / \ |
  • deleting all cached docs from Office Upload Center
  • updating Office
  • resetting OneDrive by opening it with the /reset switch
  • worked with the exact same docs with no error on other computers

Anyone have any ideas?  I feel like the % is a big clue.  Thanks.

4 Replies

@Derek Gillespie 


Just out of interest, can you try setting up a different Windows profiles on the computer for her, and try syncing again and seeing if that works?  If it works fine with the same account on other computers, I just wonder if it might be something in the profile?  Long shot, but worth a try maybe?

@PeterRisingthanks for the reply - valid option but I was hoping to try other fixes first.  I forgot to mention I did run the MS Support and Recovery Assistant and it found a problem with some of her OneNote notebooks being saved in OneDrive for Business.  The tool automatically moved them out and I ran the OneDrive reset after.

@Derek Gillespie 


But the SARA did not fix the issue completely though?

@PeterRisingno, the SARA tool didn't fix it.