One Drive Context Menu Share Button Missing!

Copper Contributor

Good Day All,


So I manage an enterprise account which has one drive for business. Recently I have noticed that users complain about the "Share" Context Menu Item is missing! I can confirm it is missing and uninstalling and re-installing One drive Either Downloaded / from the microsoft store does not resolve the issue.


The button in question is the following:




I have tried some "Fixes" from the Infamous google search engine such as a registry edit to the following key:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers\ FileSyncEx]


And this one:

Windows Registry Editor Version 5.00



[HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers\ FileSyncEx]






[HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers\ESET Security Shell]


[HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers\Open With]

[HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers\Open With EncryptionMenu]




@="Taskband Pin"

@="Start Menu Pin"





[HKEY_CLASSES_ROOT\*\shellex\PropertySheetHandlers\FCI Properties]


@="OLE DocFile Property Page"

@="Summary Properties Page"


Yet nothing seems to get it back! Can any Microsoft Personel or those of you here just helping please help me before I lose myself slowly...

17 Replies
I have this same exact issue, however its isolated to Windows 11. Searching some other post I see several resolved the issue by disabling UAC restarting and/or enabling UAC & restarting then however this did not work for me as I already had it disabled when I upgraded from Win10 to Win11.

I have the same problem in Windows 11. I tried every single solution I found in internet (except to delete the user and recreate it again) and nothing helped. It's just the buggy Microsoft software... At least I came to a workaround - I noticed that if I open the location of the OneDrive.lnk file and right-click on it some magic happens and the OneDrive context menu starts working. So I copied OneDrive.lnk to the root of my OneDrive folder, now when I right click it the functionality comes back.
Microsoft, it's a shame - your own cloud service doesn't work correctly on your own OS!

@nassoo I'll likely get this escalated with Microsoft directly since we haven't heard anything back from the community forum with any of the official Microsoft personnel. Unfortunately, I have to speak with our managed service provider to do the escalation since I am not a global admin in our Microsoft Admin Center. I have a meeting with them today so I will raise the question. They have multiple clients... somebody must have reported the same symptoms. I'll keep you posted with what I learn later on today. 

Thanks a lot! I'll be very grateful if you share the news :)
This workaround actually also worked for me - thanks!!



You mean disabling UAC?

No, sorry. The threading here doesn’t work like I was expecting. UAC had no impact for me whatsoever. But copying a OneDrive.lnk in the main folder miraculous worked. Very odd behavior. I had this issue for many weeks now and so far, this workaround shows good results.
Wow... I did the same just now & it works... Microsoft... what is this about?

Have you given that resolution provided by Alexander a try?
nassoo's workaround is working for us! Like he said, no other options (UAC or installing for /allusers) worked, but this does.

The one issue is it doesn't seem to last for very long, so make sure to put it somewhere easy for the user to get to.

@adenman thanks for the advice. Appreciate the follow up. 

Wow. The OneDrive "Share" menu item broke on all 45 of my workstations with no warning and no solution, until I found this. I have no idea WTF is going on here or how you figured it out but I really, REALLY appreciate you posting this. It is indeed the only thing that fixed it for us.


However, deleting the OneDrive link out of the folder removes the Share item and so far I've not been able to get it to come back again. So if you do use this solution to fix it, just leave it alone once it's working again.

@nassoo Hi, where would I expect to find the onedrive.lnk file?  I've searched for onedrive.lnk in file explorer and nothing shows up.



I believe its just a shortcut icon that you shorten the name on.




@MAS-PLK HI, yes I thought it would just be a shortcut but I don't have one.  If I create one the target is "C:\Users\xxxxx\OneDrive" is that the target that is in the shortcut mentioned in this thread?  If so it doesn't work for me or is the target something that OneDrive created when installed?



You are correct. That shortcut target should be the OneDrive directory under the users directory. That was all I did was create the shortcut & placed it in the root of the OneDrive directory. I may have restarted my computer & what not & I also completed the other steps they mentioned above but yes, that was all I simply did was create the shortcut, shorten the name to remove the "- shortcut" part & place it in the directory.

@MAS-PLK hi, thanks. I'll try it again as it didn't seem to work so I was checking it wasn't the onedrive icon that's put on the desktop when OD installs (which I've long since deleted as I hate stuff on the desktop)