Missing OneDrive context menu in windows 10

Copper Contributor

Hi, I'm missing the context menu on synced OneDrive for Business files. The icons on the cloud status are visible, but in the right-click menu I have no section on OneDrive. 

So no chance of changing the status to "Always Keep on device".

Is there a registry key missing or what can I do to get it back?

Ondrive client works otherwise without any problems!




55 Replies

@Waddoisn't the group policy manager only available for professional editions, not home? Either way, I don't have it currently.

@PhillipM maybe you can try this to enable UAC, in the search box type UAC and press enter, where is the slider on yours? You need it one down from top, then reboot.


Or go into the registry and enable it. Path 

EnableLUA click that and make the dword 1 in value data and reboot.

 If it was set to 0, then the above may fix it for you. 

@Waddo People should stop propagating this as a solution, when it's neither a solution or the genesis.

What causes this is quite simple. A few months back, MS changed the way the installer works. Default settings now are per user, and not per machine. If you simply download the OneDrive installer, and instead of double clicking to install, go to the command line, run the installer like this: "OneDriveSetup.exe /allusers". Once you do that, reboot, and your context menu and all features will be back.

@WaddoNow that I think of it and realize what we mean by UAC, that seems highly unlikely to fix my problem because I have UAC disabled on 2 computers, but only my laptop is having the context menu issue. Nonetheless, I adjusted the UAC slider and I'm about to check my context menus after rebooting. If that doesn't fix it (or if the fix doesn't persist after I disable UAC again because frankly, I find UAC to be more annoying than helpful/protective), I'll try running the installer with @BentleyC's extra argument, and go from there if that doesn't work. Will edit or reply to this message accordingly within about half an hour.

thank you both for the help, in any event.

edit: okay, I guess I stand corrected. While UAC probably isn't the cause of the problem, enabling it, restarting, and then disabling it and restarting again seems to have fixed my issue. Thanks @Waddo 

@PhillipM glad you got it sorted with the UAC change, thanks for the update. UAC is annoying but it is there for a reason.


We run over 1000 windows 10 machines in different locations around the globe and this is always the fix. We have had different System Admins make changes to UAC for certain APPs, like remote install of Sophos AV, and straight away One Drive Context menu disappears. Revert back = Fixed.


@BentleyC - As you can see nothing to do with the installer. UAC is the solution. Why are you installing One drive when it is built in? Thats the bit that has me stumped. Apology not required. You are spreading mis information. Even Microsoft have posted the fix for this which is UAC. :)


One drive is built in, no install required, so nothing to do with the installer, did you just make that up or have real world experience going around in circles with this? One Drive is installed already on the win10 machines from new build, so you just sign in as each user for different profiles and Bingo you have one drive with no installation. All our Staff when Hot desk simply login to the Desktop and using SSO they have one drive automatically.




@Waddo Wow, someone in charge of "a 1000 systems" who doesn't have the reading comprehension of a 6 year old. Scary.

He didn't say your fix worked, he said he was skeptical. 

The fix _I_ posted also comes from Microsoft. So apology necessary from YOU.

If you have an older installed version of Windows 10, prior to 1903, the installed version does not have this issue. 

Check yourself pal.

Read the last sentence of his reply. :)

Ok so if the Fix for "missing context menu for One drive" is not to simply enable UAC correctly and reboot, but as you suggest re-install One drive using /allusers switch, even though One drive is installed for all users by default and all they need to do is simply sign in?

I would say you need to spread your vast expertise and knowledge around, its not fair you keeping all this to yourself.

@Waddo Thanks for this advice as enabling UAC worked for me.  Context menus are now present. 


In my case OneDrive on 1909 was not running for some reason. Might have been as a result of a reboot after an WU had gone off as the auto login to Windows was nixed as well. No other issues with UAC, but as others can attest, it's a Home edition, which cuts out a lot of troubleshooting options.

Just went to this directory and started OneDrive.exe


OneDrive on the Context menu is back!

Offtopic: @Waddo can we have a chat- it's related to Sophos. Thanks .:)


I am shocked. I followed this thread. Tried the reinstall like twice, then did the UAC and it did not work after my first reboot. I went into my explorer and the context menus did not show with onedrive options. So I went in and set the UAC slider to the same level. pressed Save and it worked!!!! My context menus were back. Wish this topic was shorter and just cut to the solutions of enable UAC, Reboot, then Set UAC setting. Thx all for the help.

No need to re-enable UAC.


- Open Programs and Features

- Remove Onedrive

- Download latest Onedrive installer (use Google/Bing to look for link)

- Use cmd/powershell to install it with "OneDriveSetup.exe /AllUsers"

- It'll start syncing and show the context menu just fine with UAC off


Glad I found the switch here and glad I don't have to use UAC.

I hate UAC.

@BallsOfSteel420 Great find, thanks for sharing.  That worked for me.  I can't help with your hate issues for the UAC ;)


For those who might not be familiar with Powershell, you will need to run the command that @BallsOfSteel420 mentioned as ".\onedrivesetup.exe /AllUsers"


Download latest OneDriveSetup HERE  

@Speier  could you help me to install the one drive file downloaded from the link you provided via cmd. The .exe file is located in my downloads section in C I am just an average computer and i am not savvy in using cmd. Please help

@Waddo ,


Enabling UAC worked for me. I had to disable it to install an work related application.

For me it was the solution described in this forum:


In Short, change the following registry key:


Especially if the current setting is 0


It only works after a restart!

@MarWerNo That works for me. Thanks for sharing! :smile:

@Daniel Teixeira Thank you.  This is a nice article but it does not seem to be relevant for our problem.


The "Save files locally" is missing.  I did not see that in the article.

best response confirmed by Daniel Teixeira (Microsoft)

@donreak Hi there,

Our documentation changes with time and the article I previously mention is one of them.

For the OneDrive missing context menu we have now this one  - 

Hope this helps

Thank you @Daniel Teixeira 


Removing and Reinstlling using /allusers switch did the trick.