Keep files on my device has crashed Windows 10

Copper Contributor

Hi All,

Please help!!!!  OD has disabled my personal laptop and I’m hoping you smart folks can advise me how to recover.  What do I do next to recover with least damage?

My objective was a simple real-time cloud backup of my files whilst retaining the master files locally on my machine.  What I have now is a laptop that can’t currently open an Explorer window and complete the green sweeping wait bar.  As it fails to do this, CPU is at 3%, Memory is 6Gb of 16, SSD 1TB disk is at 0%, and 30MB network is at 100k.

I asked OD App to backup Desktop, Documents, Downloads, Pictures.  It moved files off my laptop into cloud storage.  I enabled ‘keep files on my device’ at root level.  OD downloaded copies until my C: drive was brimmed full.  I deleted 5GB of files using a DOS window in the hope it win10 would recover, but it has not.

Thanks in advance for your advice!

Mike

4 Replies

@Mikey63  You appear to have done a lot to your computer, particularly deleting files in what may have been a counterproductive move. Deleting files from a command window while the OneDrive agent is running is probably giving it even more work to do to try to repair sync relationships.

 

From your description have OneDrive holding more files in total than your hard drive available space: the folders you added plus whatever was there that you asked to be brought down to your hard drive. Was there a reason for that?

 

I would log out of OneDrive and do some local Windows repairs in Safe Mode before looking at it again.  Other file-intensive processes such as AntiVirus software will amplify any issue you have so disable those

 

Verify that you have proper backups of your files, as deleting files from OneDrive locally (rather than clearing space) will replicate deletions in the cloud. If your local actions remove those files from Recycle Bin then you may lose files.

 

 

@Mike Williams 

Thank you for taking the time to reply: I much appreciate it.

 

On local repairs, I ran chkdsk c: /f from a cmd prompt safe reboot and it found 0 unindexed files, and failed to write the event log with 'status 6'. Same on repeat so I ran chkdsk c: /r with the same result. My uneducated theory: at a higher level there's double entry of multiple files, but at CMD level empty reserved space for OD is acceptable. In Win10 Explorer is still strangled. What should I try next: can I force a rebuild of Explorer's file directory? I'm most interested in what to try next.
Thanks in advance Mike.


Below just answers your questions.  What I did was demonstrably wrong: it just lets you know what a user with half the pictrue might do.

On deleting files, there was only one. With C: brimmed, I was thinking that windows had no working disk space and this would cause issues. I confirmed that a 4Gb dashcam file was backed up and then deleted only that. I don’t have control over Windows Explorer yet so I can’t check what my OD folder says about accounts, but if I run up the OD App it reports not signed in with a grey cloud and strikethrough (systray) so I think it can’t be sync’ing.

 

You are right about more allocated than physical space. Whilst Explorer is overloaded, Ace Utilities will analyse my disc. Users\[Me]\Documents folder is emptied but had a subfolder, \Pictures is gone so I assume uploaded, emptied and deleted.

 

On the question of write-back, I naïvely thought that with ‘Keep a copy on my device’ I was asking OD to copy to the cloud and leave the existing file in place rather than move to the cloud then move back to a different location all lumped together by category on C:\..\OD

 

Good advice re: AV but McAfee blocks me from closing/blocking it using access permissions both as an app and a service. I can see a security argument for that.

Regards, Mikey63

I think I've discovered why Win10 is desperately confused: the drive letters are reset. I have 5 visible partitions: C, F, G, P, W. I booted to a safe cmd window, which required my bitlocker key. I wanted to run chkdsk on the other partitions. I thought I would have to unlock the other partitions but I tried F and it was already unlocked (I deduce C: unlocks the disk). Next, I thought I'd map the Recovery Keys with their partitions using
manage-bde -protectors -get <drive>
which worked for C, F and G: but G: reported my W partition label, and W: gave a syntax error, as did P:. The new mapping is C=>C, D=>P, E=>G, F=>F, and G=>W: according to the safe cmd mode. Diskpart correctly reported partition labels and sizes, and chkdsk found no lost files or USN (?) journal errors on any partition.

Back in Windows, Ace Utilities is able to correctly identify and label all partitions, although some of the sizes are out by 10's GB. Windows Disk Management correctly identifies letters and sizes, which agree with what I recall setting up and what safe CMD reported. CMD in Win10 can also find and navigate around the correct partition letters. I don't know as much about GPT - I thought the equivalent of the partition table was distributed - but it seems there is a native copy somewhere, which is still correct: whilst Explorer uses the one in which drive letters are re-assigned. Anyone seen this before, & or have a solution?
Thanks for the help, Mike

So the desperately confused application is Windows Explorer: which, of course, underpins any file operations. I can't tell you what 'My PC' knows because it fails to complete the search.
The McAfee issue sounds pertinent but quite honestly the more mucking around under the hood goes on I think the bigger the risk of damage.

I repeat the need to ensure you gave backups off device and outside the OneDrive system. A repair/refresh of Windows may be required at this stage.