Files [READ ONLY] but no indication they are, so cannot save changes

Bronze Contributor

I have the latest (ends in .1212) client and am still seeing an issue that has been there since the initial release back in Sept/Oct.


I can open a file in Excel, either from the MRU list in Excel, using the File|Open menu, or double-clicking on a file in Windows Explorer. (Win10).


The file opens and there is no yellow bar that says it is read only with the [EDIT] button to use the file. The title bar in Excel with the file name doesn't say [READ ONLY].


You only find out it is read only when you try to save, and Excel tells you you cannot and then offers to save a copy.


The fix is to close and reopen the file. Then the yellow EDIT bar comes up. But of course you've lost any changes.


This never happened with the old Groove client, so this is something unique to this new much improved client.


I've reported this through official channels via the REPORT A PROBLEM menu in OneDrive but nothing ever substantive comes from it. "Run a /reset command", "reinstall", "resync the library", "oh yeah, we know about that, thanks"


But we are getting close to release and I'd love to see this fixed.

46 Replies

Does it happen with libraries that require check out, or libraries with required columns or metadata?

These are just standard Sharepoint libraries. We've not modified the defaults for whatever Office 365 (business) requires. We do NOT have anything requiring checkout.


Note: as stated in the OP, the fix is to close and reopen the file, then it works fine, so that seems to indicate a bug and not a setting as a setting would not be overridden by closing/reopening.


Unless the setting was "Require user to open, close, then open the file before actually being able to use." Smiley Frustrated

Out of curiosity, do you have the preview key in the registry?

Yes. AFAIK it won't work without it and GROOVE.EXE will continue to run. GROOVE.EXE is not in my Task Manager. OneDrive has taken over. As pointed out in the OP by my version number. 

How do you remove the Read-Only so you can edit the file. Most spreadsheets are a work in progress where you publish and then change the sheet.

You cannot. Once this happens, the only fix is to close and reopen the file. If you've mace changes, you have to save the file with a different name, close it, then delete the old file, rename the new file to the old name, and open it.


Of course, you lose all history of the old file when you do this.


This is still happening today even though MS has released the new client out of beta, and still no repsonse from them. 

This is exactly what I have seen since using the /takeover and utilizing the new NG OneDrive. Here are the specifics:


I did the onedrive.exe /takeover option and it shut down Groove, and took over syncing the sites that were already on my machine. I noticed it retained the folder name of "Sharepoint" under the hood, even thought it looks like (in File Explorer) that the folder name is our company name (like "Contoso"). It spent the next 30 minutes or so re-syncing things, so even though the process says that nothing will need to be downloaded, apparently quite a bit actually did need to be (not sure why).


It eventually completed, and had errors because it doesn't appear to like to sync empty folders. Is that a problem that will be fixed? If we have a placeholder folder, why does the entire file structure need an overlay of a red "X"?


What i'm seeing now is that whenever I open an Excel doc either by double-clicking on it in Explorer, or by first opening Excel, and then selecting it from my recent list of items, it will open the document, but no longer gives me the option at the top (in the yellow bar) that says "READ-ONLY  We opened this workbook read-only from the server.", and then a button to "Edit Workbook". Prevoiusly, all opened Excel files would do this, and although some people found it annoying, it was actually a great step to prevent accidental changes of the files.


Actually, I should say sometimes it gives me that message, but almost always when it does, clicking on "Edit Workbook" comes back with "We are having problems contacting your server...check with IT" or something like that. And that message just continually comes up with no resolution. You have to close and re-open the file and hope for a different result this time.


And then when you open the file and it does not show the yellow bar with the READ ONLY, I go ahead and make changes to the file, and attempt to save it, and then it tells me that it's read-only and cannot be saved! And there is now no way to "Edit Workbook", so the only choice is to lose all changes, or save it under another name, copy over the original file, etc. A real pain.


Does the "Use Office 2016 to sync Office files that I open" setting have anything to do with this? I just attempted to uncheck that, and after restarting OneDrive, I am now randomly seeing the "READ ONLY...Edit Workbook" message when I open certain files, and when I click "Edit Workbook" it does seem to be working. But, it is still often opening the file without that message...and then I'm stuck having to save the file before I do anything to "test" if it's read-only (not ideal, because it updates the file date/time even when I haven't done anything).


Are there known bugs like this still in the works? So far, I'm not planning to move our team from Groove if this unreliableness continues...


Is there any chance a fix is in the works for this? I don't know if the fix is with the client, or something on the server side...



Months later I continue to see the same thing Luke. I have to close the file and reopen, and sometimes close Excel and reopen, which is a real pain if I have multiple files open and am in the middle of a project.


And if you make changes you need to save and this happens, you have to save the file as a different name in a different location, then name it the same as the old file, close Excel, then copy the newer version on top of the older version.


If you save as a different name, the delete the old and rename the new, you lose all saved history for that file in the Sharepoint/OneDrive/Group file system.


This needs to be fixed. This is still on .1212.


We are seeing this for those that ran /takeover and for those that installed the new Sharepoint Onedrive client fresh.

Last night I re-checked the box under settings "Use Office 2016 to sync Office files that I open". Initially, several Excel docs I opened all gave me the READ ONLY prompt, when I clicked "Edit Workbook", it actually worked! Then I went to the other site I have synced (I have 3) and opened an Excel doc, and this time, no READ ONLY prompt. And yes, when I attempted to save, it told me it couldn't contact the server so I would have to save it under another name.


Today I was mostly getting the READ ONLY yellow bar, and when clicking "Edit Workbook" I was getting the "Can't contact server" message. I'd close the doc and re-open it, until I got it to open without the READ ONLY message in the yellow bar. Then I could make a test change, and save it, and watch it do the "upload to sharepoint" in the status bar at the bottom...and then be ok. Sometimes it would fail and I'd have to re-open, but once it updated successfully, it would always update from that point on until I closed it.


I also noticed that opening it from the "Recent Files" list (opening Excel first, rather than double-clicking on it in the file explorer) would almost never give me the READ ONLY yellow bar, and it would almost always fail to save ("Can't contact server"). I'd have to close it, and then open it from file explorer...sometimes a few order for it to work.


Would be nice if anyone from MS could weigh in. Is there anywhere to see a list of reported bugs or at least what they are currently working on? Have you guys submitted this through the Report a Problem menu when you right-click on the System Tray menu? I'm about to do that...

"Have you guys submitted this through the Report a Problem menu when you right-click on the System Tray menu? I'm about to do that..."




When I did that, they send me instructions to reset my OneDrive setting to "clear the issue up."

  1. It wiped out ALL of my preferences in OneDrive, both personal and business
  2. It reset every site to full download, rechecking every box I had unchecked in every site I was syncing.


I didn't realize what had happened until OD was well on its way to downloading some 200GB of files to my machine and I had to scramble to uncheck things then wait for it to realize I had unchecked, then remove those folders I didn't want.


When I then told the MS rep what happened, she said "Yeah, that happens. And we know about the bug but wanted to see if that fixed it for you" knowing darn well it hadn't for anyone else and the issue is fundamental to the product and not anything on my machine.


So if you get any response to run the onedrive.exe with the "/reset" switch, just delete the email and go about your day.


Same thing if you get an email saying to use the /update switch, or the /uninstall switch. If you have .1212, you just have to wait.

Thanks for the heads-up. Sounds just as useful (ha!) as the "Repair" option was under GROOVE.EXE.


Despite their promise that using the /takeover would not have to download any files, it honestly appeared that it did just about as much as a new sync. There is one other guy on our team who recently did an OS re-install, and so he triggered the sync with the new client He was telling me last night that he IS getting the READ ONLY prompt all the time, and I don't think he's seeing what I'm seeing, so it probably would be worth me just doing a full re-sync (stopping the sync of the libraries, deleting the folders, deleting the cache folder, etc.) to see if it resolves it.


One of the things I liked about the /takeover was that the old folder path used "Sharepoint" but now it uses "Contoso" (although as you see in my message, the folder name is still really Sharepoint if you use /takeover!). That actually works well for us, because we have macros that run and expect the local sync folder location to have the name "Sharepoint" and we knew were were going to have to update all of them to use the company name now. Using /takeover, I didn't have to do that. Now, I do think that you can select your folder when you sync, but I don't know if OneDrive will still put "CompanyName\SiteName -Shared Documents" under the folder you select, or just "SiteName-SharedDocuments" under the folder you select. If it is the latter, we can still put it under Sharepoint.


But, if these issues are the result of the /takeover not working right, then I should just re-sync and see if that works, and we'll have to bite the bullet and update our macros.

Thank you Ed for the meticulous documentation of this issue.  We see the same behavior:  not every open of a file, but a lot of them, result in unexpected read-only.  It seems to happen most frequently when opening through the MRU menu.  Using the latest NGSC and Office suite.  Would love to hear from Microsoft on this.

This morning I stopped syncing the one site that I used, deleted the "SiteName - Documents" folder (after backing it up), and re-synced the entire site (by browsing to the site in my browser, and clicking on the Sync icon).


It synced the entire thing, and now every single Excel doc I click on shows the READ ONLY yellow bar (which is good!), BUT when I click "Edit Workbook" it says "We're having trouble connecting to the server. If this keeps happening, contact your help desk". If I browse to the file on Office 365 within the browser, and click on it, it opens. Then if I click Edit in Excel, it opens in Excel, but the exact same thing happens...I get the yellow bar, and clicking on "Edit Workbook" gives me the same message.


As Dale pointed out, I used to see this issue more from the MRU menu as it happens from the MRU or from File Explorer, or from sharepoint within the browser.


The only way I've been able to edit my documents is to go to the OneDrive settings and uncheck the "Use Office 2016 to sync Office files that I open" checkbox on the Office tab. That allows me to open the file...and so far, if I make changes and save it, it works. Although I'm concerned about whether I'm stepping on another user when I do so...or if I'm going to get the random "we can't save your changes because the file is ready only" popup (even though it doesn't tell me that when it initially opens).


I thought doing a re-sync would work. Maybe I need to re-sync ALL my sites? What about deleting the OfficeCache folder under AppData? Is that still necessary, or was that more related to Groove? I have not tried that yet.


Also, I'm considering wiping out my Office entries in the Windows Credential Manager. Perhaps something is out of sync there? Clearly the message I'm getting is bizarre because my machine clearly can connect to the server, or none of this would by syncing, etc.


Oh, I also when to File / Info in Excel, and it kept telling me I had local changes that could not be synced with the server, and I told it to discard them and get the latest from the server, and it closed the doc, but then just left me with a blank Excel shell. It never grabbed the latest doc, but also gave me no messages.


I also tried going to File / Account and under "Add a Service" re-entered my Office 365 credentials to connect to "Office 365 Sharepoint", but it didn't seem to make a difference. (It was already showing "Sites - CompanyName" under Connected Services, but I thought I'd try anyway.)


I also agree...I'd love to hear from Microsoft on this.

I would love to hear from MS too, but no clue how to get them engaged. :(

I have seen @Patricia Hendricks Balik helping some other people, maybe she can provide some insight

Please note that the new version of OneDrive DOES NOT FIX THIS.

Version 2016 (Build 17.3.6798.0207) on Windows 10.


Just ran into this again today:

  • Opened file in Teams telling it to open in Excel
  • File opened in Excel.
  • Does not say READ ONLY in header, and the yellow "edit" bar did not show up.
  • Tried to save changes to file and was told it was read only and to save a copy.
  • Closed file without saving and reopened.
  • This time the yellow "EDIT" bar showed up.

Come on MS. How much time and/or data is lost due to this?

The only way I have got round this is to un-sync the site and revert to navigating the SharePoint site and opening into Excel that way.  Still breaks my preferred workflow, but it may help you for now.  

@Rob Farnell wrote:

The only way I have got round this is to un-sync the site and revert to navigating the SharePoint site and opening into Excel that way.  Still breaks my preferred workflow, but it may help you for now.  

Well, you've "fixed" the OneDrive bug by not using OneDrive. Not really a fix.