Files not registering until after computer reboot

Copper Contributor

Please help. We use OneDrive at work. As of this last week all of a sudden I can't find files or folders until after I reboot my computer. I spend most of my days creating an excel file turning it into a pdf and emailing to off to a client. All of a sudden I have to reboot my computer in order to attach the file as most of the time the file and sometimes even the folder will not show on my computer until I reboot my computer.


I tried closing out of my email, closing out of the excel file, closing out of file explorer, putting the computer to sleep. Reopening everything in different combinations. Nothing short of rebooting the computer makes the files accessible to attach to emails (and now find in file explorer). I am able to open the excel file via recent files in the excel program only. It doesn't show in recent files in File explorer.


Any ideas? Is my computer just too old? I'm running windows 10 on an i7 purchased something like 10+ years ago.

1 Reply


1.Reset OneDrive: If restarting doesn’t work, you can try "resetting OneDrive".

To do this, right-click the OneDrive icon on the taskbar, and then click “Close OneDrive.”

Reopen OneDrive and check if everything is working correctly. If that fails, enter the full file path to the OneDrive executable in a Run window followed by “/reset” to completely reset OneDrive.


2.Check for Updates: Make sure your Windows 10 and OneDrive are up-to-date. Sometimes, updating to the latest version can resolve issues.


3.Reinstall OneDrive: If none of the above solutions work, you might want to consider reinstalling OneDrive.


Remember to always back up your files before making any changes to avoid data loss. If none of these solutions work, it might be a good idea to reach out to Microsoft Support for further assistance.


As for your computer’s age, a 10-year-old computer should still be able to run Windows 10 and OneDrive without major issues, provided it has been well-maintained and its hardware is still functioning properly.





If I have answered your question, please mark your post as Solved

If you like my response, please give it a Like :smile:

Appreciate your Kudos! Proud to contribute! :)